aboutsummaryrefslogtreecommitdiffstats
path: root/packages/classpath
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-10-05 15:31:06 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-10-05 15:31:06 +0000
commit6265c89321d13996212881744128bd4ee25b202b (patch)
tree8913b87edafede39e983b6acd503ef7cd53875d4 /packages/classpath
parentcc25c30cd5285bda5f6043e6f27fa819498c6a0b (diff)
downloadopenembedded-6265c89321d13996212881744128bd4ee25b202b.tar.gz
classpath-initial 0.93: Fixed installation locations.
Diffstat (limited to 'packages/classpath')
-rw-r--r--packages/classpath/classpath-initial_0.93.bb8
-rw-r--r--packages/classpath/classpath-native_0.97.2.bb15
2 files changed, 18 insertions, 5 deletions
diff --git a/packages/classpath/classpath-initial_0.93.bb b/packages/classpath/classpath-initial_0.93.bb
index 59a36b6cd4..5a471b3808 100644
--- a/packages/classpath/classpath-initial_0.93.bb
+++ b/packages/classpath/classpath-initial_0.93.bb
@@ -5,7 +5,7 @@ require classpath-native.inc
DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native."
-PR = "r3"
+PR = "r4"
DEPENDS = "zip-native fastjar-native jikes-native gettext-native"
@@ -23,7 +23,7 @@ EXTRA_OECONF = "\
--disable-dssi \
--disable-examples \
--disable-tools \
- --with-glibj-dir=${STAGING_DATADIR}/classpath-initial \
- --with-native-libdir=${STAGING_LIBDIR}/classpath-initial \
- --includedir=${STAGING_INCDIR}/classpath-initial \
+ --with-glibj-dir=${STAGING_DATADIR_NATIVE}/classpath-initial \
+ --with-native-libdir=${STAGING_LIBDIR_NATIVE}/classpath-initial \
+ --includedir=${STAGING_INCDIR_NATIVE}/classpath-initial \
"
diff --git a/packages/classpath/classpath-native_0.97.2.bb b/packages/classpath/classpath-native_0.97.2.bb
index cec256ecc2..3046ff44c1 100644
--- a/packages/classpath/classpath-native_0.97.2.bb
+++ b/packages/classpath/classpath-native_0.97.2.bb
@@ -1,6 +1,6 @@
require classpath-native.inc
-PR = "r2"
+PR = "r3"
# The code affected by the javanet-local patch
# is usually not compiled. However if someone changes
@@ -16,3 +16,16 @@ SRC_URI += "\
file://cp-byte-loophelper.patch;patch=1;pnum=0 \
"
+do_unpackpost() {
+ # Kind of patch: Moves package "org.w3c.dom.html2" to "org.w3c.dom.html"
+ mv external/w3c_dom/org/w3c/dom/html2 \
+ external/w3c_dom/org/w3c/dom/html
+
+ find gnu/classpath/examples/html gnu/xml/dom/html2 external/w3c_dom/org/w3c/dom/html -name "*.java" \
+ -exec sed -i -e"s|org.w3c.dom.html2|org.w3c.dom.html|" {} \;
+
+ sed -i -e"s|org/w3c/dom/html2|org/w3c/dom/html|" external/w3c_dom/Makefile.am
+}
+
+addtask unpackpost after do_unpack before do_patch
+