aboutsummaryrefslogtreecommitdiffstats
path: root/packages/classpath
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-10-10 14:04:57 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-10-10 14:04:57 +0000
commit8933c2ee3cb60f69fa4dea00a8950475c4583f61 (patch)
tree82957bd532a5c9ecf8ff650926bf5b45be46821d /packages/classpath
parentcf2a6858576fa48baf9a764f39d3b2c8711624d7 (diff)
downloadopenembedded-8933c2ee3cb60f69fa4dea00a8950475c4583f61.tar.gz
classpath-native 0.97.2: Added patch to fix a possible miscompilation with gcc 4.3.2 (from Debian Lenny).
Diffstat (limited to 'packages/classpath')
-rw-r--r--packages/classpath/classpath-native_0.97.2.bb3
-rw-r--r--packages/classpath/files/miscompilation.patch13
2 files changed, 15 insertions, 1 deletions
diff --git a/packages/classpath/classpath-native_0.97.2.bb b/packages/classpath/classpath-native_0.97.2.bb
index 81ffad3b14..0024136b97 100644
--- a/packages/classpath/classpath-native_0.97.2.bb
+++ b/packages/classpath/classpath-native_0.97.2.bb
@@ -1,6 +1,6 @@
require classpath-native.inc
-PR = "r3"
+PR = "r4"
# The code affected by the javanet-local patch
# is usually not compiled. However if someone changes
@@ -14,6 +14,7 @@ SRC_URI += "\
file://autotools.patch;patch=1 \
file://decimalformat.patch;patch=1 \
file://cp-byte-loophelper.patch;patch=1;pnum=0 \
+ file://miscompilation.patch;patch=1 \
"
do_unpackpost() {
diff --git a/packages/classpath/files/miscompilation.patch b/packages/classpath/files/miscompilation.patch
new file mode 100644
index 0000000000..c61b214f44
--- /dev/null
+++ b/packages/classpath/files/miscompilation.patch
@@ -0,0 +1,13 @@
+Index: classpath-0.97.2/native/jni/java-io/java_io_VMFile.c
+===================================================================
+--- classpath-0.97.2.orig/native/jni/java-io/java_io_VMFile.c 2008-10-10 15:24:54.000000000 +0200
++++ classpath-0.97.2/native/jni/java-io/java_io_VMFile.c 2008-10-10 15:25:36.000000000 +0200
+@@ -439,7 +439,7 @@
+ {
+ #ifndef WITHOUT_FILESYSTEM
+ const char *filename;
+- int result;
++ volatile int result;
+
+ /* Don't use the JCL convert function because it throws an exception
+ on failure */