aboutsummaryrefslogtreecommitdiffstats
path: root/packages/classpath
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-04-28 13:01:33 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-28 13:01:33 +0000
commit035fad89cb3ce035197191bdaaf9265b99f98a0b (patch)
tree90d184d57d2ecf7ed6995425af0acea5a03b1a73 /packages/classpath
parentcc133962bb715feca1e50189ca58594a13d246f1 (diff)
downloadopenembedded-035fad89cb3ce035197191bdaaf9265b99f98a0b.tar.gz
classpatch: add 0.90, closes #858
Diffstat (limited to 'packages/classpath')
-rw-r--r--packages/classpath/classpath-gtk_0.90.bb16
-rw-r--r--packages/classpath/classpath-minimal_0.90.bb16
-rw-r--r--packages/classpath/classpath.inc28
-rw-r--r--packages/classpath/files/fix-endian-arm-floats.patch11
4 files changed, 71 insertions, 0 deletions
diff --git a/packages/classpath/classpath-gtk_0.90.bb b/packages/classpath/classpath-gtk_0.90.bb
new file mode 100644
index 0000000000..ca36e675bc
--- /dev/null
+++ b/packages/classpath/classpath-gtk_0.90.bb
@@ -0,0 +1,16 @@
+include classpath.inc
+
+DEPENDS = "glib-2.0 gtk+ libart-lgpl pango libxtst jikes-native zip-native"
+RDEPENDS_${PBN}-gtk = "${PBN}-common (>= ${PV})"
+RCONFLICTS_${PBN}-gtk = "${PBN}-minimal"
+
+EXTRA_OECONF = "--with-jikes"
+
+PACKAGES = "${PBN}-dev ${PBN}-doc ${PBN}-common ${PBN}-examples ${PBN}-tools ${PN}"
+
+FILES_${PBN}-doc = "${datadir}/info"
+FILES_${PBN}-dev = "${includedir}"
+FILES_${PN} = "${libdir}"
+FILES_${PBN}-common = "${datadir}/${PBN}/glibj.zip"
+FILES_${PBN}-examples = "${datadir}/${PBN}/examples"
+FILES_${PBN}-tools = "${datadir}/${PBN}/tools"
diff --git a/packages/classpath/classpath-minimal_0.90.bb b/packages/classpath/classpath-minimal_0.90.bb
new file mode 100644
index 0000000000..4f08466e55
--- /dev/null
+++ b/packages/classpath/classpath-minimal_0.90.bb
@@ -0,0 +1,16 @@
+include classpath.inc
+
+DEPENDS = "jikes-native zip-native"
+RDEPENDS_${PBN}-minimal = "${PBN}-common (>= ${PV})"
+RCONFLICTS_${PBN}-minimal = "${PBN}-gtk"
+
+EXTRA_OECONF = "--with-jikes --without-x --with-glibj --disable-gtk-peer --disable-alsa"
+
+PACKAGES = "${PBN}-dev ${PBN}-doc ${PBN}-common ${PBN}-examples ${PBN}-tools ${PN}"
+
+FILES_${PBN}-doc = "${datadir}/info"
+FILES_${PBN}-dev = "${includedir}"
+FILES_${PN} = "${libdir}"
+FILES_${PBN}-common = "${datadir}/${PBN}/glibj.zip"
+FILES_${PBN}-examples = "${datadir}/${PBN}/examples"
+FILES_${PBN}-tools = "${datadir}/${PBN}/tools"
diff --git a/packages/classpath/classpath.inc b/packages/classpath/classpath.inc
new file mode 100644
index 0000000000..cbbab0ad16
--- /dev/null
+++ b/packages/classpath/classpath.inc
@@ -0,0 +1,28 @@
+DESCRIPTION = "GNU Classpath standard Java libraries"
+HOMEPAGE = "http://www.gnu.org/software/classpath/"
+LICENSE = "Classpath"
+PRIORITY = "optional"
+SECTION = "libs"
+
+PBN = "classpath"
+
+SRC_URI = "${GNU_MIRROR}/classpath/${PBN}-${PV}.tar.gz \
+ file://disable-automake-checks.patch;patch=1 \
+ file://fix-endian-arm-floats.patch;patch=1"
+
+S = ${WORKDIR}/${PBN}-${PV}
+
+inherit autotools
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/classpath
+ install -m 0755 include/jni* ${STAGING_INCDIR}/classpath/
+}
+
+do_install() {
+ autotools_do_install
+ mv ${D}${libdir}/security ${D}${libdir}/${PBN}
+}
+
+PROVIDES = "classpath"
+RPROVIDES = "classpath"
diff --git a/packages/classpath/files/fix-endian-arm-floats.patch b/packages/classpath/files/fix-endian-arm-floats.patch
new file mode 100644
index 0000000000..a9af0611b2
--- /dev/null
+++ b/packages/classpath/files/fix-endian-arm-floats.patch
@@ -0,0 +1,11 @@
+--- classpath/native/fdlibm/ieeefp.h.orig 2006-04-14 22:33:09.000000000 -0400
++++ classpath/native/fdlibm/ieeefp.h 2006-04-14 22:41:46.000000000 -0400
+@@ -13,7 +13,7 @@
+ byte ordering was big or little endian depending upon the target.
+ Modern floating-point formats are naturally ordered; in this case
+ __VFP_FP__ will be defined, even if soft-float. */
+-#ifdef __VFP_FP__
++#ifdef __SOFTFP__
+ #ifdef __ARMEL__
+ #define __IEEE_LITTLE_ENDIAN
+ #else