aboutsummaryrefslogtreecommitdiffstats
path: root/packages/classpath
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2005-07-17 19:37:24 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-17 19:37:24 +0000
commit2250567f7e1ed2633e136e56e250fa006706bad7 (patch)
treeebcdf047303fad1a749493295d3a27e8682c6c0e /packages/classpath
parenta7ad3651f6fc5ecf543246094a4786310e24bcb1 (diff)
downloadopenembedded-2250567f7e1ed2633e136e56e250fa006706bad7.tar.gz
classpath: upgrade to 0.16
Diffstat (limited to 'packages/classpath')
-rw-r--r--packages/classpath/classpath_0.16.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/classpath/classpath_0.16.bb b/packages/classpath/classpath_0.16.bb
new file mode 100644
index 0000000000..3e1f51afd4
--- /dev/null
+++ b/packages/classpath/classpath_0.16.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "GNU Classpath standard Java libraries"
+HOMEPAGE = "http://www.gnu.org/software/classpath/"
+LICENSE = "Classpath"
+PRIORITY = "optional"
+MAINTAINER = "Rene Wagner <rw@handhelds.org>"
+SECTION = "libs"
+PR = "r0"
+
+DEPENDS = "glib-2.0 gtk+ libart-lgpl pango jikes-native"
+RDEPENDS_${PN} = "${PN}-common (${PV})"
+
+SRC_URI = "${GNU_MIRROR}/${PN}/${P}.tar.gz \
+ file://disable-automake-checks.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-jikes"
+
+PACKAGES += " ${PN}-common ${PN}-examples"
+
+FILES_${PN} = "${libdir}/${PN}"
+FILES_${PN}-common = "${datadir}/${PN}/glibj.zip"
+FILES_${PN}-examples = "${datadir}/${PN}/examples"
+
+do_install() {
+ autotools_do_install
+ mv ${D}${libdir}/security ${D}${libdir}/${PN}
+}