aboutsummaryrefslogtreecommitdiffstats
path: root/packages/classpath
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-05-23 19:16:48 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-05-23 19:16:48 +0000
commitcd93cd62db9b4462932ef66a00f163d3286b2a34 (patch)
treea42e19be0f8b6632196114f5adc6bc5d348488f7 /packages/classpath
parent5599260fe5f7d401bc36c677245511855b63318c (diff)
downloadopenembedded-cd93cd62db9b4462932ef66a00f163d3286b2a34.tar.gz
classpath: update from Andrew Paulsen. partly closes 2296.
* update classpath-gtk. fix $PN-issue. * add classpath-gtk_cvs * add classpath-minimal-native
Diffstat (limited to 'packages/classpath')
-rw-r--r--packages/classpath/classpath-gtk_0.90.bb16
-rw-r--r--packages/classpath/classpath-gtk_0.93.bb16
-rw-r--r--packages/classpath/classpath-gtk_cvs.bb45
-rw-r--r--packages/classpath/classpath-minimal-native_0.93.bb17
-rw-r--r--packages/classpath/classpath.inc2
-rw-r--r--packages/classpath/files/gconf_version.patch11
6 files changed, 90 insertions, 17 deletions
diff --git a/packages/classpath/classpath-gtk_0.90.bb b/packages/classpath/classpath-gtk_0.90.bb
deleted file mode 100644
index b83d23d9c0..0000000000
--- a/packages/classpath/classpath-gtk_0.90.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-require classpath.inc
-
-DEPENDS = "glib-2.0 gtk+ libart-lgpl pango libxtst jikes-native zip-native"
-RDEPENDS_${PBN}-gtk = "${PBN}-common (>= ${PV})"
-RCONFLICTS_${PBN}-gtk = "${PBN}-minimal"
-
-EXTRA_OECONF = "--with-jikes"
-
-PACKAGES = "${PBN}-dev ${PBN}-doc ${PBN}-common ${PBN}-examples ${PBN}-tools ${PN}"
-
-FILES_${PBN}-doc = "${datadir}/info"
-FILES_${PBN}-dev = "${includedir}"
-FILES_${PN} = "${libdir}"
-FILES_${PBN}-common = "${datadir}/${PBN}/glibj.zip"
-FILES_${PBN}-examples = "${datadir}/${PBN}/examples"
-FILES_${PBN}-tools = "${datadir}/${PBN}/tools"
diff --git a/packages/classpath/classpath-gtk_0.93.bb b/packages/classpath/classpath-gtk_0.93.bb
new file mode 100644
index 0000000000..9577947a0c
--- /dev/null
+++ b/packages/classpath/classpath-gtk_0.93.bb
@@ -0,0 +1,16 @@
+require classpath.inc
+
+DEPENDS = "glib-2.0 gtk+ cairo gconf libart-lgpl pango libxtst jikes-native zip-native"
+RDEPENDS_${PN} = "classpath-common (>= ${PV})"
+RCONFLICTS_${PN} = "classpath-minimal"
+
+EXTRA_OECONF = "--with-jikes --disable-plugin --disable-dssi"
+
+PACKAGES = "classpath-dev classpath-doc classpath-common classpath-examples classpath-tools ${PN}"
+
+FILES_classpath-doc = "${datadir}/info"
+FILES_classpath-dev = "${includedir}"
+FILES_${PN} = "${libdir} ${bindir}"
+FILES_classpath-common = "${datadir}/classpath/glibj.zip"
+FILES_classpath-examples = "${datadir}/classpath/examples"
+FILES_classpath-tools = "${datadir}/classpath/tools.zip"
diff --git a/packages/classpath/classpath-gtk_cvs.bb b/packages/classpath/classpath-gtk_cvs.bb
new file mode 100644
index 0000000000..111f1bf6b8
--- /dev/null
+++ b/packages/classpath/classpath-gtk_cvs.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "GNU Classpath standard Java libraries"
+HOMEPAGE = "http://www.gnu.org/software/classpath/"
+LICENSE = "Classpath"
+PRIORITY = "optional"
+SECTION = "libs"
+
+SRCDATE_${PN} ?= "20070501"
+PV = "0.93+cvs${SRCDATE}"
+
+DEPENDS = "glib-2.0 gtk+ cairo gconf ecj-native zip-native"
+RDEPENDS_${PN} = "classpath-common (>= ${PV})"
+RCONFLICTS_${PN} = "classpath-minimal"
+
+SRC_URI = "cvs://anonymous@cvs.savannah.gnu.org/sources/classpath;module=classpath \
+ file://disable-automake-checks.patch;patch=1"
+
+S = "${WORKDIR}/classpath"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-ecj=${STAGING_BINDIR_NATIVE}/ecj --with-ecj-jar=${STAGING_BINDIR_NATIVE}/ecj.jar --disable-plugin --disable-dssi --disable-alsa"
+
+PACKAGES = "classpath-dev classpath-doc classpath-common classpath-examples classpath-tools ${PN}"
+
+FILES_classpath-doc = "${datadir}/info ${datadir}/man"
+FILES_classpath-dev = "${includedir}"
+FILES_${PN} = "${libdir} ${bindir}"
+FILES_classpath-common = "${datadir}/classpath/glibj.zip"
+FILES_classpath-examples = "${datadir}/classpath/examples"
+FILES_classpath-tools = "${datadir}/classpath/tools.zip"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/classpath
+ install -m 0755 include/jni* ${STAGING_INCDIR}/classpath/
+ install -d ${STAGING_DATADIR}/classpath
+ install -m 0755 lib/glibj.zip ${STAGING_DATADIR}/classpath/
+}
+
+do_install() {
+ autotools_do_install
+ mv ${D}${libdir}/security ${D}${libdir}/${PN}
+}
+
+PROVIDES = "classpath"
+RPROVIDES = "classpath"
diff --git a/packages/classpath/classpath-minimal-native_0.93.bb b/packages/classpath/classpath-minimal-native_0.93.bb
new file mode 100644
index 0000000000..05fd9b8557
--- /dev/null
+++ b/packages/classpath/classpath-minimal-native_0.93.bb
@@ -0,0 +1,17 @@
+inherit native
+require classpath.inc
+
+DEPENDS = "glib-2.0 libart-lgpl pango libxtst jikes-native zip-native"
+
+EXTRA_OECONF = "--with-jikes --disable-gconf-peer --disable-gtk-peer --disable-plugin --disable-dssi --disable-examples"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/classpath
+ install -m 0755 include/jni* ${STAGING_INCDIR}/classpath/
+ install -d ${STAGING_DATADIR}/classpath
+ install -m 0755 lib/glibj.zip ${STAGING_DATADIR}/classpath/
+}
+
+do_install() {
+ :
+}
diff --git a/packages/classpath/classpath.inc b/packages/classpath/classpath.inc
index 303c286d4e..459788c93a 100644
--- a/packages/classpath/classpath.inc
+++ b/packages/classpath/classpath.inc
@@ -8,7 +8,7 @@ PBN = "classpath"
SRC_URI = "${GNU_MIRROR}/classpath/${PBN}-${PV}.tar.gz \
file://disable-automake-checks.patch;patch=1 \
- file://fix-endian-arm-floats.patch;patch=1"
+ file://gconf_version.patch;patch=1"
S = "${WORKDIR}/${PBN}-${PV}"
diff --git a/packages/classpath/files/gconf_version.patch b/packages/classpath/files/gconf_version.patch
new file mode 100644
index 0000000000..b1be1209a2
--- /dev/null
+++ b/packages/classpath/files/gconf_version.patch
@@ -0,0 +1,11 @@
+--- classpath-0.93/configure.ac~ 2007-03-29 15:52:30.000000000 -0500
++++ classpath-0.93/configure.ac 2007-03-29 15:52:30.000000000 -0500
+@@ -496,7 +496,7 @@
+
+ dnl gconf-peer
+ if test "x${COMPILE_GCONF_PEER}" = xyes; then
+- PKG_CHECK_MODULES(GCONF, gconf-2.0 >= 2.11.2)
++ PKG_CHECK_MODULES(GCONF, gconf-2.0 >= 2.6.0)
+ AC_SUBST(GCONF_CFLAGS)
+ AC_SUBST(GCONF_LIBS)
+ dnl we also need gdk for locking