aboutsummaryrefslogtreecommitdiffstats
path: root/packages/classpath
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-06-19 10:30:29 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-06-19 10:30:29 +0000
commitf53f96335ecc987fa9b8df806c375d2d2955a968 (patch)
tree25dd3b5cd13fa8000c33bedd9776b82bf846b969 /packages/classpath
parent6a5d18a241746736f548ce5d5e6c315f1f50f53a (diff)
downloadopenembedded-f53f96335ecc987fa9b8df806c375d2d2955a968.tar.gz
classpath: fix compilation failure of classpath-gtk_cvs. Closes 2519.
* add libxtst to DEPENDS * fix packaging * move stuff to *.inc (unify)
Diffstat (limited to 'packages/classpath')
-rw-r--r--packages/classpath/classpath-gtk_cvs.bb13
-rw-r--r--packages/classpath/classpath.inc13
2 files changed, 15 insertions, 11 deletions
diff --git a/packages/classpath/classpath-gtk_cvs.bb b/packages/classpath/classpath-gtk_cvs.bb
index 690fb761b7..18d79decae 100644
--- a/packages/classpath/classpath-gtk_cvs.bb
+++ b/packages/classpath/classpath-gtk_cvs.bb
@@ -1,12 +1,12 @@
require classpath.inc
-PR = "r1"
+PR = "r2"
SRCDATE_${PN} ?= "20070501"
PV = "0.93+cvs${SRCDATE}"
### note from Laibsch: bug 2523 has information on how to build this package
-DEPENDS = "glib-2.0 gtk+ cairo gconf ecj-native zip-native virtual/java-native"
+DEPENDS = "glib-2.0 gtk+ cairo gconf ecj-native zip-native virtual/java-native libxtst"
RDEPENDS_${PN} = "classpath-common (>= ${PV})"
RCONFLICTS_${PN} = "classpath-minimal"
@@ -17,15 +17,6 @@ S = "${WORKDIR}/classpath"
EXTRA_OECONF = "--with-ecj=${STAGING_BINDIR_NATIVE}/ecj --with-ecj-jar=${STAGING_BINDIR_NATIVE}/ecj.jar --disable-plugin --disable-dssi --disable-alsa"
-PACKAGES = "classpath-dev classpath-doc classpath-common classpath-examples classpath-tools ${PN}"
-
-FILES_classpath-doc = "${datadir}/info ${datadir}/man"
-FILES_classpath-dev = "${includedir}"
-FILES_${PN} = "${libdir} ${bindir}"
-FILES_classpath-common = "${datadir}/classpath/glibj.zip"
-FILES_classpath-examples = "${datadir}/classpath/examples"
-FILES_classpath-tools = "${datadir}/classpath/tools.zip"
-
do_stage() {
install -d ${STAGING_INCDIR}/classpath
install -m 0755 include/jni* ${STAGING_INCDIR}/classpath/
diff --git a/packages/classpath/classpath.inc b/packages/classpath/classpath.inc
index 1d684c0557..db75d52a5c 100644
--- a/packages/classpath/classpath.inc
+++ b/packages/classpath/classpath.inc
@@ -28,3 +28,16 @@ FILES_classpath-common += "${datadir}/classpath/glibj.zip"
FILES_classpath-examples += "${datadir}/classpath/examples"
FILES_classpath-tools += "${datadir}/classpath/tools.zip ${datadir}/classpath/tools"
FILES_classpath-dev += "${libdir}/*.so"
+FILES_classpath-dbg += "${libdir}/classpath/.debug"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/classpath
+ install -m 0755 include/jni* ${STAGING_INCDIR}/classpath/
+ install -d ${STAGING_DATADIR}/classpath
+ install -m 0755 lib/glibj.zip ${STAGING_DATADIR}/classpath/
+}
+
+do_install() {
+ autotools_do_install
+ mv ${D}${libdir}/security ${D}${libdir}/${PN}
+}