aboutsummaryrefslogtreecommitdiffstats
path: root/packages/console-tools
diff options
context:
space:
mode:
authorDavid Karlstrom <daka@thg.se>2005-07-23 13:36:38 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-23 13:36:38 +0000
commit5e01906b8433bc6a8c03be2e31758589641124c9 (patch)
treec400790ffa5ebb896c464da84752a4937d889400 /packages/console-tools
parent57808a977840bce11bdbab373d9eacaba7ef88c1 (diff)
downloadopenembedded-5e01906b8433bc6a8c03be2e31758589641124c9.tar.gz
Updated to use update-alternatives and fix some FHS bugs
Diffstat (limited to 'packages/console-tools')
-rw-r--r--packages/console-tools/console-tools_0.3.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/console-tools/console-tools_0.3.2.bb b/packages/console-tools/console-tools_0.3.2.bb
index 7cf684c589..2a94a4f896 100644
--- a/packages/console-tools/console-tools_0.3.2.bb
+++ b/packages/console-tools/console-tools_0.3.2.bb
@@ -1,6 +1,7 @@
SECTION = "base"
LICENSE = "GPL"
DESCRIPTION = "Allows you to set-up and manipulate the Linux console."
+PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
file://codepage.patch;patch=1 \
@@ -23,3 +24,23 @@ do_compile () {
}
inherit autotools
+
+do_install () {
+ autotools_do_install
+ mv ${D}${bindir}/chvt ${D}${bindir}/chvt.${PN}
+ mv ${D}${bindir}/deallocvt ${D}${bindir}/deallocvt.${PN}
+ mv ${D}${bindir}/openvt ${D}${bindir}/openvt.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/chvt chvt chvt.${PN} 100
+ update-alternatives --install ${bindir}/deallocvt deallocvt deallocvt.${PN} 100
+ update-alternatives --install ${bindir}/openvt openvt openvt.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove chvt chvt.${PN}
+ update-alternatives --remove deallocvt deallocvt.${PN}
+ update-alternatives --remove openvt openvt.${PN}
+}
+