aboutsummaryrefslogtreecommitdiffstats
path: root/packages/coreutils
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-10-23 08:27:20 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-10-23 08:27:20 +0000
commit9b832cc20708630c465eb783e312239297a61ab9 (patch)
tree7f46dfa1491ec32f69a987f82445bfeb2c75247d /packages/coreutils
parent9da76f0fa1bcbe23adce375c7fe31de6e59e788b (diff)
downloadopenembedded-9b832cc20708630c465eb783e312239297a61ab9.tar.gz
coreutils 5.3: Fix for glibc 2.5 by renaming the tee function to tee_files
to prevent a conflict with the tee function definied by glibc 2.5 The name tee_files is what is used in newer coreutils distriubtions. See bug #1483.
Diffstat (limited to 'packages/coreutils')
-rw-r--r--packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch33
-rw-r--r--packages/coreutils/coreutils_5.3.0.bb5
2 files changed, 36 insertions, 2 deletions
diff --git a/packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch b/packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch
new file mode 100644
index 0000000000..148a5f4f8f
--- /dev/null
+++ b/packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch
@@ -0,0 +1,33 @@
+Glibc 2.5 has a function called tee which conflicts with the same function
+in coreutils. This patch renames the function to tee_files (as is done in
+the newer coreutils versions.)
+
+--- coreutils-5.3.0/src/tee.c 2006/10/23 07:35:00 1.1
++++ coreutils-5.3.0/src/tee.c 2006/10/23 07:35:16
+@@ -31,7 +31,7 @@
+
+ #define AUTHORS "Mike Parker", "Richard M. Stallman", "David MacKenzie"
+
+-static bool tee (int nfiles, const char **files);
++static bool tee_files (int nfiles, const char **files);
+
+ /* If true, append to output files rather than truncating them. */
+ static bool append;
+@@ -121,7 +121,7 @@
+ /* Do *not* warn if tee is given no file arguments.
+ POSIX requires that it work when given no arguments. */
+
+- ok = tee (argc - optind, (const char **) &argv[optind]);
++ ok = tee_files (argc - optind, (const char **) &argv[optind]);
+ if (close (STDIN_FILENO) != 0)
+ error (EXIT_FAILURE, errno, _("standard input"));
+
+@@ -133,7 +133,7 @@
+ Return true if successful. */
+
+ static bool
+-tee (int nfiles, const char **files)
++tee_files (int nfiles, const char **files)
+ {
+ FILE **descriptors;
+ char buffer[BUFSIZ];
diff --git a/packages/coreutils/coreutils_5.3.0.bb b/packages/coreutils/coreutils_5.3.0.bb
index 759e9a4017..fa05a83781 100644
--- a/packages/coreutils/coreutils_5.3.0.bb
+++ b/packages/coreutils/coreutils_5.3.0.bb
@@ -3,11 +3,12 @@ LICENSE = "GPL"
SECTION = "base"
RREPLACES = "textutils shellutils fileutils"
RPROVIDES = "textutils shellutils fileutils"
-PR = "r0"
+PR = "r1"
SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
file://install-cross.patch;patch=1;pnum=0 \
- file://man.patch;patch=1"
+ file://man.patch;patch=1 \
+ file://rename-tee-for-glibc2.5.patch;patch=1"
SRC_URI += "file://uptime-pow-lib.patch;patch=1"