aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ctorrent
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-08-10 05:00:30 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-10 05:00:30 +0000
commitd718ec6e34553f5d6b967860b4c78a313864fb9d (patch)
tree214a57a311e8c59d07e364651de0b9bdc6eede18 /packages/ctorrent
parentd55a8660b010aec1543b4acd7a8b43e6de7ca846 (diff)
downloadopenembedded-d718ec6e34553f5d6b967860b4c78a313864fb9d.tar.gz
Added alignment patch, passkey and configure patch.
Diffstat (limited to 'packages/ctorrent')
-rw-r--r--packages/ctorrent/ctorrent_1.3.4.bb9
-rw-r--r--packages/ctorrent/files/configure.patch29
-rw-r--r--packages/ctorrent/files/passkey.patch16
3 files changed, 51 insertions, 3 deletions
diff --git a/packages/ctorrent/ctorrent_1.3.4.bb b/packages/ctorrent/ctorrent_1.3.4.bb
index 55b2fb91df..087823cdb4 100644
--- a/packages/ctorrent/ctorrent_1.3.4.bb
+++ b/packages/ctorrent/ctorrent_1.3.4.bb
@@ -1,8 +1,11 @@
include ctorrent.inc
-PR = "r3"
+PR = "r4"
-SRC_URI += "file://nogetwd.patch;patch=1 \
+SRC_URI += "file://configure.patch;patch=1 \
+ file://align.patch;patch=1 \
+ file://nogetwd.patch;patch=1 \
file://crash.patch;patch=1 \
file://fmt.patch;patch=1 \
file://stall.patch;patch=1 \
- file://tracker.patch;patch=1"
+ file://tracker.patch;patch=1 \
+ file://passkey.patch;patch=1"
diff --git a/packages/ctorrent/files/configure.patch b/packages/ctorrent/files/configure.patch
new file mode 100644
index 0000000000..95fe5cc2be
--- /dev/null
+++ b/packages/ctorrent/files/configure.patch
@@ -0,0 +1,29 @@
+diff -ur ctorrent/configure ctorrent.new/configure
+--- ctorrent/configure 2004-09-09 00:10:51.000000000 +0100
++++ ctorrent.new/configure 2005-01-23 18:29:34.000000000 +0000
+@@ -3216,13 +3216,13 @@
+
+ else
+
+-echo "$as_me:$LINENO: checking for SHA1_Init in -lcrypt" >&5
+-echo $ECHO_N "checking for SHA1_Init in -lcrypt... $ECHO_C" >&6
++echo "$as_me:$LINENO: checking for SHA1_Init in -lcrypto" >&5
++echo $ECHO_N "checking for SHA1_Init in -lcrypto... $ECHO_C" >&6
+ if test "${ac_cv_lib_crypt_SHA1_Init+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lcrypt $LIBS"
++LIBS="-lcrypto $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ /* confdefs.h. */
+@@ -3275,7 +3275,7 @@
+ #define HAVE_LIBCRYPT 1
+ _ACEOF
+
+- LIBS="-lcrypt $LIBS"
++ LIBS="-lcrypto $LIBS"
+
+ else
+
diff --git a/packages/ctorrent/files/passkey.patch b/packages/ctorrent/files/passkey.patch
new file mode 100644
index 0000000000..3debc44599
--- /dev/null
+++ b/packages/ctorrent/files/passkey.patch
@@ -0,0 +1,16 @@
+*** ctorrent/httpencode.cpp.orig Thu Sep 9 01:10:51 2004
+--- ctorrent/httpencode.cpp Thu Aug 4 15:00:45 2005
+***************
+*** 88,94 ****
+--- 88,98 ----
+
+ /* path */
+ if( *p != '/' ) return -1;
++ #if 1 /* The passkey patch */
++ for( ; *p; p++,path++) *path = *p;
++ #else
+ for( ; *p && *p != '?'; p++,path++) *path = *p;
++ #endif
+ *path = '\0';
+ return 0;
+ }