aboutsummaryrefslogtreecommitdiffstats
path: root/packages/cumulus
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/cumulus
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/cumulus')
-rw-r--r--packages/cumulus/cumulus_1.2.bb36
-rw-r--r--packages/cumulus/cumulus_cvs.bb20
2 files changed, 46 insertions, 10 deletions
diff --git a/packages/cumulus/cumulus_1.2.bb b/packages/cumulus/cumulus_1.2.bb
index e69de29bb2..01af252e44 100644
--- a/packages/cumulus/cumulus_1.2.bb
+++ b/packages/cumulus/cumulus_1.2.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "A flightcomputer application for Qt/E based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+APPTYPE = "binary"
+APPNAME = "cumulus"
+APPDESKTOP = "${S}"
+PR = "r0"
+
+SRC_URI = "http://cumulus.kflog.org/download/src/cumulus-${PV}.src.tar.bz2 \
+ file://qtooltip.patch;patch=1"
+S = "${WORKDIR}/cumulus-arm-${PV}/cumulus"
+
+inherit opie
+
+export OE_QMAKE_LINK="${CXX}"
+EXTRA_QMAKEVARS_POST = "INCLUDEPATH+=-I."
+
+#
+# nasty hack since cumulus doesn't obey the qmake standard which requires just one .pro file per directory
+#
+do_compile() {
+ qmake -makefile -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} cumulus.pro
+ oe_runmake
+ qmake -makefile -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} gpsClient.pro
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/mapicons
+ install -m 0644 ../cumulus.png ${D}${palmtopdir}/pics/cumulus.png
+ cp -a map-icons/* ${D}${palmtopdir}/pics/mapicons
+
+ install -m 0755 gpsClient ${D}${palmtopdir}/bin/
+}
diff --git a/packages/cumulus/cumulus_cvs.bb b/packages/cumulus/cumulus_cvs.bb
index 0677d0769b..d6f8e51064 100644
--- a/packages/cumulus/cumulus_cvs.bb
+++ b/packages/cumulus/cumulus_cvs.bb
@@ -29,15 +29,15 @@ do_compile() {
}
do_install() {
- install -d ${D}/${palmtopdir}/pics/mapicons \
- ${D}/${palmtopdir}/pics/mapicons/small \
- ${D}/${palmtopdir}/pics/mapicons/windarrows
- install -m 0644 ../cumulus.png ${D}/${palmtopdir}/pics/cumulus.png
- install -m 0644 map-icons/*.png ${D}/${palmtopdir}/pics/mapicons
- install -m 0644 map-icons/*.xpm ${D}/${palmtopdir}/pics/mapicons
- install -m 0644 map-icons/small/*.png ${D}/${palmtopdir}/pics/mapicons/small
- install -m 0644 map-icons/small/*.xpm ${D}/${palmtopdir}/pics/mapicons/small
- install -m 0644 map-icons/windarrows/*.png ${D}/${palmtopdir}/pics/mapicons/windarrows
+ install -d ${D}${palmtopdir}/pics/mapicons \
+ ${D}${palmtopdir}/pics/mapicons/small \
+ ${D}${palmtopdir}/pics/mapicons/windarrows
+ install -m 0644 ../cumulus.png ${D}${palmtopdir}/pics/cumulus.png
+ install -m 0644 map-icons/*.png ${D}${palmtopdir}/pics/mapicons
+ install -m 0644 map-icons/*.xpm ${D}${palmtopdir}/pics/mapicons
+ install -m 0644 map-icons/small/*.png ${D}${palmtopdir}/pics/mapicons/small
+ install -m 0644 map-icons/small/*.xpm ${D}${palmtopdir}/pics/mapicons/small
+ install -m 0644 map-icons/windarrows/*.png ${D}${palmtopdir}/pics/mapicons/windarrows
- install -m 0755 gpsClient ${D}/${palmtopdir}/bin/
+ install -m 0755 gpsClient ${D}${palmtopdir}/bin/
}