aboutsummaryrefslogtreecommitdiffstats
path: root/packages/cups
diff options
context:
space:
mode:
authorJoaquim Duran <joaquinduran@adtelecom.es>2007-08-02 12:14:14 +0000
committerKoen Kooi <koen@openembedded.org>2007-08-02 12:14:14 +0000
commit0913e0e77fb336111552ddfde1944bcfd0b3c25f (patch)
treec9e7d0a75acdc0d9e872400a58694797dbd85d13 /packages/cups
parent570262e75e01c7ce404f0a292e8e8f637a304f60 (diff)
downloadopenembedded-0913e0e77fb336111552ddfde1944bcfd0b3c25f.tar.gz
cups: update to 1.2.12, closes #2705
Diffstat (limited to 'packages/cups')
-rw-r--r--packages/cups/cups.inc83
-rw-r--r--packages/cups/cups_1.2.10.bb83
-rw-r--r--packages/cups/cups_1.2.12.bb5
3 files changed, 90 insertions, 81 deletions
diff --git a/packages/cups/cups.inc b/packages/cups/cups.inc
new file mode 100644
index 0000000000..20cc8c39c3
--- /dev/null
+++ b/packages/cups/cups.inc
@@ -0,0 +1,83 @@
+DESCRIPTION = "An Internet printing system for Unix."
+SECTION = "console/utils"
+LICENSE = "GPL LGPL"
+DEPENDS = "gnutls jpeg dbus dbus-glib libpng zlib install-native fakeroot-native"
+
+SRC_URI = "ftp://ftp.easysw.com/pub/cups/${PV}/cups-${PV}-source.tar.bz2 \
+ "
+
+inherit autotools binconfig
+
+LDFLAGS += " -L${STAGING_LIBDIR} "
+
+EXTRA_OECONF = " \
+ --enable-gnutls \
+ --enable-dbus \
+ --enable-browsing \
+ --disable-openssl \
+ --disable-tiff \
+ --without-php \
+ --without-perl \
+ --without-python \
+ --without-java \
+ "
+
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+do_compile () {
+ sed -i s:STRIP:NOSTRIP: Makedefs
+ sed -i s:serial:: backend/Makefile
+
+ echo "all:" > man/Makefile
+ echo "install:" >> man/Makefile
+
+ oe_runmake "SSLLIBS=-lgnutls -L${STAGING_LIBDIR}" \
+ "LIBPNG=-lpng -lm -L${STAGING_LIBDIR}" \
+ "LIBJPEG=-ljpeg -L${STAGING_LIBDIR}" \
+ "LIBZ=-lz -L${STAGING_LIBDIR}" \
+ "-I."
+}
+
+fakeroot do_install () {
+ oe_runmake "DSTROOT=${D}" install
+
+ # This directory gets installed with perms 511, which makes packaging fail
+ chmod 0711 "${D}/${localstatedir}/run/cups/certs"
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/cups
+ install ${S}/cups/*.h ${STAGING_INCDIR}/cups/
+ install ${S}/filter/*.h ${STAGING_INCDIR}/cups/
+ oe_libinstall -C cups -so libcups ${STAGING_LIBDIR}
+ oe_libinstall -C filter -so libcupsimage ${STAGING_LIBDIR}
+}
+
+python do_package_append() {
+ # Change permissions back the way they were, they probably had a reason...
+ workdir = bb.data.getVar('WORKDIR', d, 1)
+ os.system('chmod 0511 %s/install/cups/var/run/cups/certs' % workdir)
+}
+
+FILES_${PN}-dbg += "${libdir}/cups/backend/.debug \
+ ${libdir}/cups/cgi-bin/.debug \
+ ${libdir}/cups/filter/.debug \
+ ${libdir}/cups/monitor/.debug \
+ ${libdir}/cups/notifier/.debug \
+ ${libdir}/cups/daemon/.debug \
+ "
+#package the html for the webgui inside the main packages (~1MB uncompressed)
+
+FILES_${PN} += "${datadir}/doc/cups/images \
+ ${datadir}/doc/cups/*html \
+ ${datadir}/doc/cups/*.css \
+ ${datadir}/icons/ \
+ "
+
+LEAD_SONAME = "libcups.so.*"
+
diff --git a/packages/cups/cups_1.2.10.bb b/packages/cups/cups_1.2.10.bb
index 2e4498255c..125fc51caf 100644
--- a/packages/cups/cups_1.2.10.bb
+++ b/packages/cups/cups_1.2.10.bb
@@ -1,83 +1,4 @@
-DESCRIPTION = "An Internet printing system for Unix."
-SECTION = "console/utils"
-LICENSE = "GPL LGPL"
-DEPENDS = "gnutls jpeg dbus dbus-glib libpng zlib install-native fakeroot-native"
-PR = "r1"
+require cups.inc
-SRC_URI = "ftp://ftp3.easysw.com/pub/cups/${PV}/cups-${PV}-source.tar.bz2 \
- "
+PR = "r2"
-inherit autotools binconfig
-
-LDFLAGS += " -L${STAGING_LIBDIR} "
-
-EXTRA_OECONF = " \
- --enable-gnutls \
- --enable-dbus \
- --enable-browsing \
- --disable-openssl \
- --disable-tiff \
- --without-php \
- --without-perl \
- --without-python \
- --without-java \
- "
-
-
-do_configure() {
- gnu-configize
- libtoolize --force
- oe_runconf
-}
-
-do_compile () {
- sed -i s:STRIP:NOSTRIP: Makedefs
- sed -i s:serial:: backend/Makefile
-
- echo "all:" > man/Makefile
- echo "install:" >> man/Makefile
-
- oe_runmake "SSLLIBS=-lgnutls -L${STAGING_LIBDIR}" \
- "LIBPNG=-lpng -lm -L${STAGING_LIBDIR}" \
- "LIBJPEG=-ljpeg -L${STAGING_LIBDIR}" \
- "LIBZ=-lz -L${STAGING_LIBDIR}" \
- "-I."
-}
-
-fakeroot do_install () {
- oe_runmake "DSTROOT=${D}" install
-
- # This directory gets installed with perms 511, which makes packaging fail
- chmod 0711 "${D}/${localstatedir}/run/cups/certs"
-}
-
-do_stage () {
- install -d ${STAGING_INCDIR}/cups
- install ${S}/cups/*.h ${STAGING_INCDIR}/cups/
- install ${S}/filter/*.h ${STAGING_INCDIR}/cups/
- oe_libinstall -C cups -so libcups ${STAGING_LIBDIR}
- oe_libinstall -C filter -so libcupsimage ${STAGING_LIBDIR}
-}
-
-python do_package_append() {
- # Change permissions back the way they were, they probably had a reason...
- workdir = bb.data.getVar('WORKDIR', d, 1)
- os.system('chmod 0511 %s/install/cups/var/run/cups/certs' % workdir)
-}
-
-FILES_${PN}-dbg += "${libdir}/cups/backend/.debug \
- ${libdir}/cups/cgi-bin/.debug \
- ${libdir}/cups/filter/.debug \
- ${libdir}/cups/monitor/.debug \
- ${libdir}/cups/notifier/.debug \
- ${libdir}/cups/daemon/.debug \
- "
-#package the html for the webgui inside the main packages (~1MB uncompressed)
-
-FILES_${PN} += "${datadir}/doc/cups/images \
- ${datadir}/doc/cups/*html \
- ${datadir}/doc/cups/*.css \
- ${datadir}/icons/ \
- "
-
-LEAD_SONAME = "libcups.so.*" \ No newline at end of file
diff --git a/packages/cups/cups_1.2.12.bb b/packages/cups/cups_1.2.12.bb
new file mode 100644
index 0000000000..4a4512d790
--- /dev/null
+++ b/packages/cups/cups_1.2.12.bb
@@ -0,0 +1,5 @@
+require cups.inc
+
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"