aboutsummaryrefslogtreecommitdiffstats
path: root/packages/db
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-08-11 20:14:09 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-11 20:14:09 +0000
commit2acf28fb2e382351b774326eff393e1f93df92e8 (patch)
treeaab0accb46aa37f3bc7707afafc5937b598b9b4c /packages/db
parent5815d684a5f291ea94e1bdb4a4cded24fb742aae (diff)
downloadopenembedded-2acf28fb2e382351b774326eff393e1f93df92e8.tar.gz
db-4: thumb only (no PR bump): prevent the erroneous use of 32 bit arm
assembly when compiling thumb instructions.
Diffstat (limited to 'packages/db')
-rw-r--r--packages/db/db_4.3.27.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/packages/db/db_4.3.27.bb b/packages/db/db_4.3.27.bb
index 3a233dcff1..216fb5714b 100644
--- a/packages/db/db_4.3.27.bb
+++ b/packages/db/db_4.3.27.bb
@@ -49,7 +49,12 @@ DB4_CONFIG ?= "--enable-o_direct --enable-smallbuild"
# the default - "POSIX/pthreads/library".
# Don't ignore the nice SWP instruction on the ARM:
EXTRA_OECONF = "${DB4_CONFIG}"
-EXTRA_OECONF_nslu2 = "${DB4_CONFIG} --with-mutex=ARM/gcc-assembly"
+# These enable the ARM assembler mutex code, this won't
+# work with thumb compilation...
+ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
+ARM_MUTEX_thumb = ""
+# NOTE: only tested on nslu2, should probably be _armeb
+EXTRA_OECONF_nslu2 = "${DB4_CONFIG} ${ARM_MUTEX}"
# Cancel the site stuff - it's set for db3 and destroys the
# configure.