aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dbus
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-09-29 07:26:28 +0000
committerKoen Kooi <koen@openembedded.org>2007-09-29 07:26:28 +0000
commitca4c0d9813a41a7908f707a17f73db7d8cf6fbac (patch)
treed7a892d8249e817e5fdfd28f73b35bbb44482adb /packages/dbus
parent56a0b8217e225655eb0031b10214120c783c8df5 (diff)
downloadopenembedded-ca4c0d9813a41a7908f707a17f73db7d8cf6fbac.tar.gz
dbus: sync with poky and use .inc file
Diffstat (limited to 'packages/dbus')
-rw-r--r--packages/dbus/dbus-1.0.2/dbus-1.init18
-rw-r--r--packages/dbus/dbus.inc19
-rw-r--r--packages/dbus/dbus_1.0.2.bb13
3 files changed, 39 insertions, 11 deletions
diff --git a/packages/dbus/dbus-1.0.2/dbus-1.init b/packages/dbus/dbus-1.0.2/dbus-1.init
index 46e321860d..0725083c69 100644
--- a/packages/dbus/dbus-1.0.2/dbus-1.init
+++ b/packages/dbus/dbus-1.0.2/dbus-1.init
@@ -62,6 +62,7 @@ start_it_up()
shut_it_down()
{
if [ -d $EVENTDIR ]; then
+ # TODO: --reverse when busybox supports it
run-parts --arg=stop $EVENTDIR
fi
echo -n "Stopping $DESC: "
@@ -75,6 +76,16 @@ shut_it_down()
rm -f $PIDFILE
}
+reload_it()
+{
+ echo -n "Reloading $DESC config: "
+ dbus-send --print-reply --system --type=method_call \
+ --dest=org.freedesktop.DBus \
+ / org.freedesktop.DBus.ReloadConfig > /dev/null
+ # hopefully this is enough time for dbus to reload it's config file.
+ echo "done."
+}
+
case "$1" in
start)
start_it_up
@@ -82,13 +93,16 @@ case "$1" in
stop)
shut_it_down
;;
- restart|force-reload)
+ reload|force-reload)
+ reload_it
+ ;;
+ restart)
shut_it_down
sleep 1
start_it_up
;;
*)
- echo "Usage: /etc/init.d/$NAME {start|stop|restart|force-reload}" >&2
+ echo "Usage: /etc/init.d/$NAME {start|stop|restart|reload|force-reload}" >&2
exit 1
;;
esac
diff --git a/packages/dbus/dbus.inc b/packages/dbus/dbus.inc
index b329e82fa3..50e0ffedc4 100644
--- a/packages/dbus/dbus.inc
+++ b/packages/dbus/dbus.inc
@@ -2,13 +2,16 @@ SECTION = "base"
HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
DESCRIPTION = "message bus system for applications to talk to one another"
LICENSE = "GPL"
-DEPENDS = "expat virtual/libintl"
+DEPENDS = "expat glib-2.0 virtual/libintl"
-SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
file://tmpdir.patch;patch=1 \
file://dbus-1.init \
- file://cross.patch;patch=1 \
- file://fix-install-daemon.patch;patch=1"
+ ${SRC_URI_EXTRA}"
+
inherit autotools pkgconfig update-rc.d gettext
@@ -17,8 +20,8 @@ INITSCRIPT_PARAMS = "defaults"
CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf"
-FILES_${PN} = "${bindir}/dbus-daemon ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${bindir}/dbus-uuidgen ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${libdir}/dbus-1.0/include"
+FILES_${PN} = "${bindir}/dbus-daemon-1 ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
pkg_postinst_dbus() {
#!/bin/sh
@@ -36,12 +39,14 @@ chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER"
}
-EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
+EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
--disable-checks --disable-xml-docs --disable-doxygen-docs \
--with-xml=expat --without-x"
+
do_stage () {
oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
+ oe_libinstall -so -C glib libdbus-glib-1 ${STAGING_LIBDIR}
autotools_stage_includes
diff --git a/packages/dbus/dbus_1.0.2.bb b/packages/dbus/dbus_1.0.2.bb
index 799509ab66..62a22254c3 100644
--- a/packages/dbus/dbus_1.0.2.bb
+++ b/packages/dbus/dbus_1.0.2.bb
@@ -1,5 +1,14 @@
require dbus.inc
-SRC_URI += " file://fix-waitpid.patch;patch=1"
+DEFAULT_PREFERENCE = "1"
+
+PR = "r5"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+ file://tmpdir.patch;patch=1 \
+ file://dbus-1.init \
+ file://cross.patch;patch=1 \
+ file://fix-install-daemon.patch;patch=1"
+
+
-PR = "r4"