aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dbus
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2005-04-02 23:18:59 +0000
committerChris Larson <clarson@kergoth.com>2005-04-02 23:18:59 +0000
commit051dc38192ed40cc675bf66103c1ad4945762899 (patch)
tree102dc4f7a2e7fec9d00e045403494038722b4668 /packages/dbus
parent0a5cefea6ad60061171c450332b35202d44c5b1a (diff)
downloadopenembedded-051dc38192ed40cc675bf66103c1ad4945762899.tar.gz
Merge oe-devel@oe-devel.bkbits.net:openembedded
into handhelds.org:/home/kergoth/code/openembedded 2005/04/02 17:30:09-05:00 handhelds.org!kergoth Apply a patch to dbus to make it use the gettext autoconf macros, so that its nls support can be disabled (note that atm it links against libintl anyway, through glib's use of it, since -lintl is in the glib .pc files). BKrev: 424f2863eUcoABD12GDxqIWbMLwsFQ
Diffstat (limited to 'packages/dbus')
-rw-r--r--packages/dbus/dbus/gettext.patch0
-rw-r--r--packages/dbus/dbus_0.20.bb31
-rw-r--r--packages/dbus/dbus_0.21.bb4
-rw-r--r--packages/dbus/dbus_0.22.bb7
-rw-r--r--packages/dbus/dbus_0.23.bb7
5 files changed, 41 insertions, 8 deletions
diff --git a/packages/dbus/dbus/gettext.patch b/packages/dbus/dbus/gettext.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus/gettext.patch
diff --git a/packages/dbus/dbus_0.20.bb b/packages/dbus/dbus_0.20.bb
index e69de29bb2..0a08862f10 100644
--- a/packages/dbus/dbus_0.20.bb
+++ b/packages/dbus/dbus_0.20.bb
@@ -0,0 +1,31 @@
+SECTION = "base"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+DEPENDS = "expat glib-2.0 virtual/libintl"
+LICENSE = "GPL"
+
+SRC_URI = "http://freedesktop.org/Software/dbus/releases/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1"
+
+inherit autotools pkgconfig gettext
+
+EXTRA_OECONF = "--disable-qt --disable-gtk --disable-tests \
+ --disable-checks --disable-xml-docs --disable-doxygen-docs \
+ --with-xml=expat --without-x"
+
+headers = "dbus-address.h dbus-bus.h dbus-connection.h dbus-errors.h dbus-macros.h dbus-memory.h dbus-message.h dbus-pending-call.h dbus-protocol.h dbus-server.h dbus-threads.h dbus-types.h dbus.h"
+
+do_stage () {
+ oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
+ oe_libinstall -so -C glib libdbus-glib-1 ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/dbus-1.0/dbus
+ for i in ${headers}; do
+ install -m 0644 dbus/$i ${STAGING_INCDIR}/dbus-1.0/dbus/$i
+ done
+
+ install -m 0644 glib/dbus-glib.h ${STAGING_INCDIR}/dbus-1.0/dbus/
+
+ mkdir -p ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
+ install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
+}
diff --git a/packages/dbus/dbus_0.21.bb b/packages/dbus/dbus_0.21.bb
index fa45aac760..abd234712f 100644
--- a/packages/dbus/dbus_0.21.bb
+++ b/packages/dbus/dbus_0.21.bb
@@ -2,14 +2,14 @@ SECTION = "base"
PR = "r4"
HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
DESCRIPTION = "message bus system for applications to talk to one another"
-DEPENDS = "expat glib-2.0"
+DEPENDS = "expat glib-2.0 virtual/libintl"
LICENSE = "GPL"
SRC_URI = "http://freedesktop.org/Software/dbus/releases/dbus-${PV}.tar.gz \
file://cross.patch;patch=1 \
file://dbus-1.init"
-inherit autotools pkgconfig update-rc.d
+inherit autotools pkgconfig update-rc.d gettext
INITSCRIPT_NAME = "dbus-1"
INITSCRIPT_PARAMS = "defaults"
diff --git a/packages/dbus/dbus_0.22.bb b/packages/dbus/dbus_0.22.bb
index e490a550c2..424c27908b 100644
--- a/packages/dbus/dbus_0.22.bb
+++ b/packages/dbus/dbus_0.22.bb
@@ -1,16 +1,17 @@
SECTION = "base"
-PR = "r5"
+PR = "r6"
HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
DESCRIPTION = "message bus system for applications to talk to one another"
LICENSE = "GPL"
-DEPENDS = "expat glib-2.0"
+DEPENDS = "expat glib-2.0 virtual/libintl"
SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
file://cross.patch;patch=1 \
file://tmpdir.patch;patch=1 \
+ file://gettext.patch;patch=1 \
file://dbus-1.init"
-inherit autotools pkgconfig update-rc.d
+inherit autotools pkgconfig update-rc.d gettext
INITSCRIPT_NAME = "dbus-1"
INITSCRIPT_PARAMS = "defaults"
diff --git a/packages/dbus/dbus_0.23.bb b/packages/dbus/dbus_0.23.bb
index f03dd6a0ce..c0faeec1a6 100644
--- a/packages/dbus/dbus_0.23.bb
+++ b/packages/dbus/dbus_0.23.bb
@@ -1,16 +1,17 @@
SECTION = "base"
-PR = "r1"
+PR = "r2"
HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
DESCRIPTION = "message bus system for applications to talk to one another"
LICENSE = "GPL"
-DEPENDS = "expat glib-2.0"
+DEPENDS = "expat glib-2.0 virtual/libintl"
SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
file://cross.patch;patch=1 \
file://tmpdir.patch;patch=1 \
+ file://gettext.patch;patch=1 \
file://dbus-1.init"
-inherit autotools pkgconfig update-rc.d
+inherit autotools pkgconfig update-rc.d gettext
INITSCRIPT_NAME = "dbus-1"
INITSCRIPT_PARAMS = "defaults"