aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dbus
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-02-19 23:42:47 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-02-19 23:42:47 +0000
commita31fef72ef3076a0250cc304c25f6a68ae2b9b9e (patch)
tree62dd8b6884270ed774d01d5c706af7ffae84fe92 /packages/dbus
parent5afdb5f594d828b1f948ea5dc7820e3d1deef4e6 (diff)
downloadopenembedded-a31fef72ef3076a0250cc304c25f6a68ae2b9b9e.tar.gz
dbus 1.1.4 fix permissions of dbus system bus activation helper binary
* with this revision, system bus activation finally works
Diffstat (limited to 'packages/dbus')
-rw-r--r--packages/dbus/dbus.inc22
-rw-r--r--packages/dbus/dbus_1.1.4.bb2
2 files changed, 17 insertions, 7 deletions
diff --git a/packages/dbus/dbus.inc b/packages/dbus/dbus.inc
index b2ced23d99..ed0a0b3cf2 100644
--- a/packages/dbus/dbus.inc
+++ b/packages/dbus/dbus.inc
@@ -1,5 +1,6 @@
+DESCRIPTION = "A message bus system for inter-process communication"
HOMEPAGE = "http://dbus.freedesktop.org"
-DESCRIPTION = "Message bus system for applications to talk to one another"
+SECTION = "base"
LICENSE = "GPL"
DEPENDS = "expat glib-2.0 virtual/libintl"
@@ -56,13 +57,20 @@ chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER"
grep -q netdev: /etc/group || addgroup netdev
-
+chmod u+s /usr/libexec/dbus-daemon-launch-helper
}
-EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
- --disable-checks --disable-xml-docs --disable-doxygen-docs \
- --with-xml=expat --without-x"
-
+EXTRA_OECONF = "\
+ --disable-qt \
+ --disable-qt3 \
+ --disable-gtk \
+ --disable-tests \
+ --disable-checks \
+ --disable-xml-docs \
+ --disable-doxygen-docs \
+ --with-xml=expat \
+ --without-x \
+"
do_stage() {
oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
@@ -76,4 +84,6 @@ do_stage() {
do_install_append() {
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
+ # the stock install seems to install the libtool wrapper script, so we have to copy this manually :M:
+ install -m 0755 bus/.libs/dbus-daemon-launch-helper ${D}${libexecdir}/
}
diff --git a/packages/dbus/dbus_1.1.4.bb b/packages/dbus/dbus_1.1.4.bb
index 8e3e329fde..7838e55ca1 100644
--- a/packages/dbus/dbus_1.1.4.bb
+++ b/packages/dbus/dbus_1.1.4.bb
@@ -1,3 +1,3 @@
include dbus.inc
-PR = "r1"
+PR = "r2"