aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ddclient
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2004-12-14 12:49:04 +0000
committerMichael Lauer <mickey@vanille-media.de>2004-12-14 12:49:04 +0000
commitfe938bbed352811a2e176797d9f5295d270564e8 (patch)
treeb482ac8d4bbe1d878d08b41d7f73d95b00459474 /packages/ddclient
parent8c45dce3743063bf4f15c5c17597fbeb15061d5f (diff)
downloadopenembedded-fe938bbed352811a2e176797d9f5295d270564e8.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2004/12/14 12:27:14+01:00 (none)!br1 Merge http://oe-devel@oe-devel.bkbits.net/openembedded into null.(none):/data/mtx/oe/openembedded 2004/12/14 12:26:43+01:00 (none)!br1 add mtx-1 i2c support 2004/12/14 11:02:03+01:00 (none)!br1 unik-olsrd 0.4.8 2004/12/14 11:00:53+01:00 (none)!br1 little fixes for bitbake 2004/12/14 10:59:06+01:00 (none)!br1 nylon updates 2004/12/14 03:27:14-06:00 ti.com!kergoth More PACKAGE_ARCH/MACHINE_ARCH updates for the multi-z builds. BKrev: 41bee140kQ_QwKwcIxgyouZUyeqwmA
Diffstat (limited to 'packages/ddclient')
-rw-r--r--packages/ddclient/ddclient_3.6.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/ddclient/ddclient_3.6.3.bb b/packages/ddclient/ddclient_3.6.3.bb
index e69de29bb2..ff1f9b5660 100644
--- a/packages/ddclient/ddclient_3.6.3.bb
+++ b/packages/ddclient/ddclient_3.6.3.bb
@@ -0,0 +1,25 @@
+SECTION = "console/network"
+DESCRIPTION = "Ddclient is a Perl client used to update dynamic DNS entries for accounts on Dynamic DNS Network Services"
+HOMEPAGE = "http://ddclient.sourceforge.net/"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ddclient/ddclient.tar.bz2 \
+ file://ip-up"
+S = "${WORKDIR}/ddclient"
+
+RDEPENDS = "perl perl-module-strict perl-module-getopt-long perl-module-vars perl-module-warnings-register perl-module-warnings perl-module-carp perl-module-exporter perl-module-constant perl-module-exporter-heavy perl-module-sys-hostname perl-module-xsloader perl-module-autoloader perl-module-io-socket perl-module-io-handle perl-module-symbol perl-module-selectsaver perl-module-io perl-module-socket perl-module-errno perl-module-config perl-module-io-socket-inet perl-module-io-socket-unix perl-module-integer"
+
+do_install() {
+ install -d ${D}/${sbindir} ${D}/${sysconfdir} ${D}/${sysconfdir}/init.d
+ install -d ${D}/${sysconfdir}/ppp/ip-up.d/ install -d ${D}/${docdir}/ddclient
+ install -m 755 ${S}/ddclient ${D}/${sbindir}
+ install ${S}/sample-etc_ddclient.conf ${D}/${sysconfdir}/ddclient.conf
+ install -m 755 ${WORKDIR}/ip-up ${D}/${sysconfdir}/ppp/ip-up.d/ddclient
+ install -m 755 ${S}/sample-etc_rc.d_init.d_ddclient ${D}/${sysconfdir}/init.d/ddclient
+ install ${S}/README* ${D}/${docdir}/ddclient
+ install ${S}/COPY* ${D}/${docdir}/ddclient
+ install ${S}/sample* ${D}/${docdir}/ddclient
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/ddclient.conf"