aboutsummaryrefslogtreecommitdiffstats
path: root/packages/devio
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-09-22 19:29:58 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-22 19:29:58 +0000
commitb58e9513f43d78e54c5f21938f74af0bccd75199 (patch)
tree3e1e358310fc98b53184f60d32f4c723adbd23dd /packages/devio
parent97c84f930e2eeb494685584a67a3a513c1af93c0 (diff)
downloadopenembedded-b58e9513f43d78e54c5f21938f74af0bccd75199.tar.gz
devio: move to devio_1.0, move to a file (not cvs) release
Diffstat (limited to 'packages/devio')
-rw-r--r--packages/devio/devio-cvs.inc16
-rw-r--r--packages/devio/devio-native.inc4
-rw-r--r--packages/devio/devio-native_1.0.bb3
-rw-r--r--packages/devio/devio-native_cvs.bb8
-rw-r--r--packages/devio/devio-native_r1.bb8
-rw-r--r--packages/devio/devio-native_r2.bb8
-rw-r--r--packages/devio/devio.inc20
-rw-r--r--packages/devio/devio_1.0.bb1
-rw-r--r--packages/devio/devio_cvs.bb27
-rw-r--r--packages/devio/devio_r1.bb26
-rw-r--r--packages/devio/devio_r2.bb26
11 files changed, 54 insertions, 93 deletions
diff --git a/packages/devio/devio-cvs.inc b/packages/devio/devio-cvs.inc
new file mode 100644
index 0000000000..10e1827ccc
--- /dev/null
+++ b/packages/devio/devio-cvs.inc
@@ -0,0 +1,16 @@
+# CVS based releases, disfavour these
+DEFAULT_PREFERENCE = "-1"
+
+include devio.inc
+
+# this is a CVS only release
+CVS_TAG ?= ";tag=${PV}"
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/devio;method=pserver;module=devio${CVS_TAG}"
+
+# This accesses the head version, anonymous pserver access is
+# only updated once per day (and it is necessary to change
+# 'jbowler' to the name of a developer with ssh access.)
+#SRC_URI = "cvs://jbowler@cvs.sourceforge.net/cvsroot/devio;method=ext;rsh=ssh;tag=HEAD;module=devio"
+
+# The source will end up in the subdirectory 'devio' - no release name
+S = "${WORKDIR}/devio"
diff --git a/packages/devio/devio-native.inc b/packages/devio/devio-native.inc
new file mode 100644
index 0000000000..1ba886c1ee
--- /dev/null
+++ b/packages/devio/devio-native.inc
@@ -0,0 +1,4 @@
+# Set the installation dir back to the default
+sbindir = "${exec_prefix}/sbin"
+
+inherit native
diff --git a/packages/devio/devio-native_1.0.bb b/packages/devio/devio-native_1.0.bb
new file mode 100644
index 0000000000..6103b3a30f
--- /dev/null
+++ b/packages/devio/devio-native_1.0.bb
@@ -0,0 +1,3 @@
+# This package builds the devio program for the build architecture
+include devio_1.0.bb
+include devio-native.inc
diff --git a/packages/devio/devio-native_cvs.bb b/packages/devio/devio-native_cvs.bb
index 6f4e9b7f7e..71c8ae679b 100644
--- a/packages/devio/devio-native_cvs.bb
+++ b/packages/devio/devio-native_cvs.bb
@@ -1,7 +1,3 @@
# This package builds the devio program for the build architecture
-include devio_${PV}.bb
-
-# Set the installation dir back to the default
-sbindir = "${exec_prefix}/sbin"
-
-inherit native
+include devio_cvs.bb
+include devio-native.inc
diff --git a/packages/devio/devio-native_r1.bb b/packages/devio/devio-native_r1.bb
index 6f4e9b7f7e..d1a25b1896 100644
--- a/packages/devio/devio-native_r1.bb
+++ b/packages/devio/devio-native_r1.bb
@@ -1,7 +1,3 @@
# This package builds the devio program for the build architecture
-include devio_${PV}.bb
-
-# Set the installation dir back to the default
-sbindir = "${exec_prefix}/sbin"
-
-inherit native
+include devio_r1.bb
+include devio-native.inc
diff --git a/packages/devio/devio-native_r2.bb b/packages/devio/devio-native_r2.bb
index 6f4e9b7f7e..624b315e68 100644
--- a/packages/devio/devio-native_r2.bb
+++ b/packages/devio/devio-native_r2.bb
@@ -1,7 +1,3 @@
# This package builds the devio program for the build architecture
-include devio_${PV}.bb
-
-# Set the installation dir back to the default
-sbindir = "${exec_prefix}/sbin"
-
-inherit native
+include devio_r2.bb
+include devio-native.inc
diff --git a/packages/devio/devio.inc b/packages/devio/devio.inc
new file mode 100644
index 0000000000..fadbd4892d
--- /dev/null
+++ b/packages/devio/devio.inc
@@ -0,0 +1,20 @@
+# This package builds the devio program
+DESCRIPTION = "devio - block devio io"
+HOMEPAGE = "http://devio.sourceforge.net/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "base"
+LICENSE = "MIT"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/devio/devio-${PV}.tar.gz"
+
+# Source directory
+S = "${WORKDIR}/devio-${PV}"
+
+# Just the one package at present
+PACKAGES = "${PN}"
+
+# Set the install dir to /sbin, not /usr/sbin, because devio is used
+# during bootstrap (we want it to be posible to mount /usr separately)
+sbindir = "/sbin"
+
+inherit autotools
diff --git a/packages/devio/devio_1.0.bb b/packages/devio/devio_1.0.bb
new file mode 100644
index 0000000000..38021fa141
--- /dev/null
+++ b/packages/devio/devio_1.0.bb
@@ -0,0 +1 @@
+include devio.inc
diff --git a/packages/devio/devio_cvs.bb b/packages/devio/devio_cvs.bb
index 3cbb2ea258..a8915bc482 100644
--- a/packages/devio/devio_cvs.bb
+++ b/packages/devio/devio_cvs.bb
@@ -1,25 +1,2 @@
-# This package builds the devio program
-PR = "r0"
-DESCRIPTION = "devio - block devio io"
-HOMEPAGE = "http://devio.sourceforge.net/"
-MAINTAINER = "John Bowler <jbowler@acm.org>"
-SECTION = "base"
-LICENSE = "MIT"
-
-SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/devio;method=pserver;module=devio"
-# This accesses the head version, anonymous pserver access is
-# only updated once per day (and it is necessary to change
-# 'jbowler' to the name of a developer with ssh access.)
-#SRC_URI = "cvs://jbowler@cvs.sourceforge.net/cvsroot/devio;method=ext;rsh=ssh;tag=HEAD;module=devio"
-
-# The source will end up in the subdirectory 'devio' - no release name
-S = "${WORKDIR}/devio"
-
-# Just the one package at present
-PACKAGES = "${PN}"
-
-# Set the install dir to /sbin, not /usr/sbin, because devio is used
-# during bootstrap (we want it to be posible to mount /usr separately)
-sbindir = "/sbin"
-
-inherit autotools
+CVS_TAG = ""
+include devio-cvs.inc
diff --git a/packages/devio/devio_r1.bb b/packages/devio/devio_r1.bb
index 4dc70b2311..66de024d1d 100644
--- a/packages/devio/devio_r1.bb
+++ b/packages/devio/devio_r1.bb
@@ -1,25 +1 @@
-# This package builds the devio program
-PR = "r0"
-DESCRIPTION = "devio - block devio io"
-HOMEPAGE = "http://devio.sourceforge.net/"
-MAINTAINER = "John Bowler <jbowler@acm.org>"
-SECTION = "base"
-LICENSE = "MIT"
-
-SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/devio;method=pserver;module=devio;tag=${PV}"
-# This accesses the head version, anonymous pserver access is
-# only updated once per day (and it is necessary to change
-# 'jbowler' to the name of a developer with ssh access.)
-#SRC_URI = "cvs://jbowler@cvs.sourceforge.net/cvsroot/devio;method=ext;rsh=ssh;tag=HEAD;module=devio"
-
-# The source will end up in the subdirectory 'devio' - no release name
-S = "${WORKDIR}/devio"
-
-# Just the one package at present
-PACKAGES = "${PN}"
-
-# Set the install dir to /sbin, not /usr/sbin, because devio is used
-# during bootstrap (we want it to be posible to mount /usr separately)
-sbindir = "/sbin"
-
-inherit autotools
+include devio-cvs.inc
diff --git a/packages/devio/devio_r2.bb b/packages/devio/devio_r2.bb
index 4dc70b2311..66de024d1d 100644
--- a/packages/devio/devio_r2.bb
+++ b/packages/devio/devio_r2.bb
@@ -1,25 +1 @@
-# This package builds the devio program
-PR = "r0"
-DESCRIPTION = "devio - block devio io"
-HOMEPAGE = "http://devio.sourceforge.net/"
-MAINTAINER = "John Bowler <jbowler@acm.org>"
-SECTION = "base"
-LICENSE = "MIT"
-
-SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/devio;method=pserver;module=devio;tag=${PV}"
-# This accesses the head version, anonymous pserver access is
-# only updated once per day (and it is necessary to change
-# 'jbowler' to the name of a developer with ssh access.)
-#SRC_URI = "cvs://jbowler@cvs.sourceforge.net/cvsroot/devio;method=ext;rsh=ssh;tag=HEAD;module=devio"
-
-# The source will end up in the subdirectory 'devio' - no release name
-S = "${WORKDIR}/devio"
-
-# Just the one package at present
-PACKAGES = "${PN}"
-
-# Set the install dir to /sbin, not /usr/sbin, because devio is used
-# during bootstrap (we want it to be posible to mount /usr separately)
-sbindir = "/sbin"
-
-inherit autotools
+include devio-cvs.inc