aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dhcdbd/dhcdbd_1.14.bb
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2006-08-24 16:21:25 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2006-08-24 16:21:25 +0000
commita4bbe9dd7f07b610bf275a1bce4829f18069f581 (patch)
tree91ec416e27d2aaa0be0ee380372023a2c6e32832 /packages/dhcdbd/dhcdbd_1.14.bb
parent4c8b88007468700648afff0a7b961e96b112e5ce (diff)
downloadopenembedded-a4bbe9dd7f07b610bf275a1bce4829f18069f581.tar.gz
dhcdbd: Add 1.14 by Milan Plzik
Diffstat (limited to 'packages/dhcdbd/dhcdbd_1.14.bb')
-rw-r--r--packages/dhcdbd/dhcdbd_1.14.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/dhcdbd/dhcdbd_1.14.bb b/packages/dhcdbd/dhcdbd_1.14.bb
new file mode 100644
index 0000000000..f46543d2d4
--- /dev/null
+++ b/packages/dhcdbd/dhcdbd_1.14.bb
@@ -0,0 +1,26 @@
+DESCRIPTION="DBus-enabled dhcp client"
+SECTION="net"
+LICENSE="GPL"
+HOMEPAGE="http://people.redhat.com/jvdias/dhcdbd/"
+MAINTAINER="Milan Plzik <mmp@handhelds.org>"
+
+DEPENDS = "dbus"
+
+SRC_URI="http://people.redhat.com/jvdias/dhcdbd/dhcdbd-${PV}.tar.gz \
+ file://dhcdbd-1.14-pkgconfig_dbus.patch;patch=1\
+ file://dhcdbd"
+
+do_configure() {
+}
+
+do_compile() {
+ CC=${TARGET_SYS}-gcc DESTDIR=${prefix} make
+}
+
+do_install() {
+ DESTDIR=${D} make install
+ install -d ${D}/etc/init.d
+ install -m 0755 ${WORKDIR}/dhcdbd ${D}/etc/init.d/
+}
+
+FILES_${PN}="${sysconfdir} ${datadir}/dbus-1 ${base_sbindir}"