aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dhcdbd
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-10-18 08:48:47 +0000
committerGraeme Gregory <dp@xora.org.uk>2006-10-18 08:48:47 +0000
commit0064f6cee7680b22a73d5834203caf0ae7b00ef9 (patch)
treee76b201437e3d835a6174642569fac71eada2072 /packages/dhcdbd
parentc52bead29e80c30f359cc129895d3db2f603364b (diff)
downloadopenembedded-0064f6cee7680b22a73d5834203caf0ae7b00ef9.tar.gz
dhcdbd_2.0.bb : new upstream version, also added patch to disable sending
-x to dhclient (which is a patch dhclient needs if it is to understand this new arg)
Diffstat (limited to 'packages/dhcdbd')
-rw-r--r--packages/dhcdbd/dhcdbd_2.0.bb25
-rw-r--r--packages/dhcdbd/files/no-ext-options.patch13
2 files changed, 38 insertions, 0 deletions
diff --git a/packages/dhcdbd/dhcdbd_2.0.bb b/packages/dhcdbd/dhcdbd_2.0.bb
new file mode 100644
index 0000000000..de9e24abd5
--- /dev/null
+++ b/packages/dhcdbd/dhcdbd_2.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION="DBus-enabled dhcp client"
+SECTION="net"
+LICENSE="GPL"
+HOMEPAGE="http://people.redhat.com/jvdias/dhcdbd/"
+
+DEPENDS = "dbus"
+RDEPENDS = "dhcp-client"
+
+PR = "r0"
+
+SRC_URI="http://people.redhat.com/dcantrel/dhcdbd/dhcdbd-${PV}.tar.bz2 \
+ file://no-ext-options.patch;patch=1 \
+ file://dhcdbd"
+
+do_compile() {
+ CC=${TARGET_SYS}-gcc DESTDIR=${prefix} make
+}
+
+do_install() {
+ DESTDIR=${D} make install
+ install -d ${D}/etc/init.d
+ install -m 0755 ${WORKDIR}/dhcdbd ${D}/etc/init.d/
+}
+
+FILES_${PN} += "${sysconfdir} ${datadir}/dbus-1 ${base_sbindir}/*"
diff --git a/packages/dhcdbd/files/no-ext-options.patch b/packages/dhcdbd/files/no-ext-options.patch
new file mode 100644
index 0000000000..774a2cf140
--- /dev/null
+++ b/packages/dhcdbd/files/no-ext-options.patch
@@ -0,0 +1,13 @@
+Index: dhcdbd-2.0/include/dhcdbd.h
+===================================================================
+--- dhcdbd-2.0.orig/include/dhcdbd.h 2006-10-18 09:38:18.000000000 +0100
++++ dhcdbd-2.0/include/dhcdbd.h 2006-10-18 09:38:45.000000000 +0100
+@@ -76,7 +76,7 @@
+ #endif
+
+ #ifndef DHCLIENT_EXTENDED_OPTION_ENVIRONMENT
+-#define DHCLIENT_EXTENDED_OPTION_ENVIRONMENT 1
++#define DHCLIENT_EXTENDED_OPTION_ENVIRONMENT 0
+ #endif
+
+ #define DHCDBD_INTERFACE_TEXT "text"