aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dhcdbd
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-08-24 20:20:25 +0000
committerKoen Kooi <koen@openembedded.org>2006-08-24 20:20:25 +0000
commit0d55561bcb5469a7c160c101e01d61dd28001dc0 (patch)
treeaabc677ca91a35fe9dac39e7c2d0601e4e6ffd9a /packages/dhcdbd
parentad4628305b3dbba5dd4f4b00af5d62083ac7507b (diff)
downloadopenembedded-0d55561bcb5469a7c160c101e01d61dd28001dc0.tar.gz
dhcdbd: add patch to make it work it the new dbus api
Diffstat (limited to 'packages/dhcdbd')
-rw-r--r--packages/dhcdbd/dhcdbd_1.14.bb10
-rw-r--r--packages/dhcdbd/files/dbus-api-fix.patch20
2 files changed, 25 insertions, 5 deletions
diff --git a/packages/dhcdbd/dhcdbd_1.14.bb b/packages/dhcdbd/dhcdbd_1.14.bb
index f46543d2d4..3194942e4e 100644
--- a/packages/dhcdbd/dhcdbd_1.14.bb
+++ b/packages/dhcdbd/dhcdbd_1.14.bb
@@ -6,13 +6,13 @@ MAINTAINER="Milan Plzik <mmp@handhelds.org>"
DEPENDS = "dbus"
+PR = "r1"
+
SRC_URI="http://people.redhat.com/jvdias/dhcdbd/dhcdbd-${PV}.tar.gz \
- file://dhcdbd-1.14-pkgconfig_dbus.patch;patch=1\
+ file://dhcdbd-1.14-pkgconfig_dbus.patch;patch=1 \
+ file://dbus-api-fix.patch;patch=1 \
file://dhcdbd"
-do_configure() {
-}
-
do_compile() {
CC=${TARGET_SYS}-gcc DESTDIR=${prefix} make
}
@@ -23,4 +23,4 @@ do_install() {
install -m 0755 ${WORKDIR}/dhcdbd ${D}/etc/init.d/
}
-FILES_${PN}="${sysconfdir} ${datadir}/dbus-1 ${base_sbindir}"
+FILES_${PN} += "${sysconfdir} ${datadir}/dbus-1 ${base_sbindir}/*"
diff --git a/packages/dhcdbd/files/dbus-api-fix.patch b/packages/dhcdbd/files/dbus-api-fix.patch
new file mode 100644
index 0000000000..ce05fc7bf8
--- /dev/null
+++ b/packages/dhcdbd/files/dbus-api-fix.patch
@@ -0,0 +1,20 @@
+--- /tmp/dbus_service.c 2006-08-24 22:09:14.000000000 +0200
++++ dhcdbd-1.14/dbus_service.c 2006-08-24 22:09:44.228306000 +0200
+@@ -1412,7 +1412,7 @@
+ return ( cs );
+
+ give_up:
+- dbus_connection_disconnect( connection );
++ dbus_connection_close( connection );
+ dbus_shutdown();
+ return ( 0L );
+ }
+@@ -1456,7 +1456,7 @@
+ cs->roots=0L;
+
+
+- dbus_connection_disconnect( cs->connection );
++ dbus_connection_close( cs->connection );
+ dbus_shutdown();
+ free( cs );
+ }