aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dhcdbd
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2006-09-15 13:36:15 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2006-09-15 13:36:15 +0000
commit2ab6f081474099fd6e359c9f3f36b78a2bd10604 (patch)
tree089e3656ebb5f1727cddead79901b89edfb62637 /packages/dhcdbd
parentfe75f8484090a1ff9573e2842f0ab9f8619f9a59 (diff)
downloadopenembedded-2ab6f081474099fd6e359c9f3f36b78a2bd10604.tar.gz
dhcdbd: Add 1.16
Diffstat (limited to 'packages/dhcdbd')
-rw-r--r--packages/dhcdbd/dhcdbd_1.16.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/dhcdbd/dhcdbd_1.16.bb b/packages/dhcdbd/dhcdbd_1.16.bb
new file mode 100644
index 0000000000..5b72bd91c8
--- /dev/null
+++ b/packages/dhcdbd/dhcdbd_1.16.bb
@@ -0,0 +1,25 @@
+DESCRIPTION="DBus-enabled dhcp client"
+SECTION="net"
+LICENSE="GPL"
+HOMEPAGE="http://people.redhat.com/jvdias/dhcdbd/"
+MAINTAINER="Milan Plzik <mmp@handhelds.org>"
+
+DEPENDS = "dbus"
+
+PR = "r0"
+
+SRC_URI="http://people.redhat.com/dcantrel/dhcdbd/dhcdbd-${PV}.tar.gz \
+ file://dhcdbd-1.14-pkgconfig_dbus.patch;patch=1 \
+ file://dhcdbd"
+
+do_compile() {
+ CC=${TARGET_SYS}-gcc DESTDIR=${prefix} make
+}
+
+do_install() {
+ DESTDIR=${D} make install
+ install -d ${D}/etc/init.d
+ install -m 0755 ${WORKDIR}/dhcdbd ${D}/etc/init.d/
+}
+
+FILES_${PN} += "${sysconfdir} ${datadir}/dbus-1 ${base_sbindir}/*"