aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dhcdbd
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2008-10-11 13:34:13 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2009-01-13 12:26:15 -0200
commit44b7ac123a781091d48736931a9111f603e62577 (patch)
treead79a07e958d30a7224d2b11619b0d1c480a9205 /packages/dhcdbd
parenta459dfb77bd4525e4dc735dcfeb53db8bf7f7bd9 (diff)
downloadopenembedded-44b7ac123a781091d48736931a9111f603e62577.tar.gz
dhcdbd: add 3.0
Besides the new version, the required changes to get the initscript properly installer has also been done.
Diffstat (limited to 'packages/dhcdbd')
-rw-r--r--packages/dhcdbd/dhcdbd_3.0.bb27
-rw-r--r--packages/dhcdbd/files/dbus_connection_unref.patch20
-rw-r--r--packages/dhcdbd/files/paths.patch25
3 files changed, 72 insertions, 0 deletions
diff --git a/packages/dhcdbd/dhcdbd_3.0.bb b/packages/dhcdbd/dhcdbd_3.0.bb
new file mode 100644
index 0000000000..a2467ee921
--- /dev/null
+++ b/packages/dhcdbd/dhcdbd_3.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "DBus-enabled dhcp client"
+SECTION = "net"
+LICENSE = "GPL"
+DEPENDS = "dbus"
+RDEPENDS = "dhcp-client"
+PR = "r1"
+
+SRC_URI = "http://dcantrel.fedorapeople.org/dhcdbd/dhcdbd-${PV}.tar.bz2 \
+ file://dbus_connection_unref.patch;patch=1 \
+ file://paths.patch;patch=1 \
+ file://dhcdbd"
+
+inherit update-rc.d
+
+do_compile() {
+ CC=${TARGET_SYS}-gcc DESTDIR=${prefix} make
+}
+
+do_install() {
+ DESTDIR=${D} make install
+ install -d ${D}/etc/init.d
+ install -m 0755 ${WORKDIR}/dhcdbd ${D}/etc/init.d/
+}
+
+INITSCRIPT_NAME = dhcdbd
+INITSCRIPT_PARAMS = "start 30 2 3 4 5 . stop 30 0 1 6 ."
+FILES_${PN} += "${sysconfdir} ${datadir}/dbus-1 ${base_sbindir}/*"
diff --git a/packages/dhcdbd/files/dbus_connection_unref.patch b/packages/dhcdbd/files/dbus_connection_unref.patch
new file mode 100644
index 0000000000..e34c30b308
--- /dev/null
+++ b/packages/dhcdbd/files/dbus_connection_unref.patch
@@ -0,0 +1,20 @@
+--- a/src/dbus_service.c.old 2006-11-29 08:32:03.390681525 +0100
++++ b/src/dbus_service.c 2006-11-29 08:32:18.847562363 +0100
+@@ -1216,7 +1216,7 @@
+ return (cs);
+
+ give_up:
+- dbus_connection_close(connection);
++ dbus_connection_unref(connection);
+ dbus_shutdown();
+
+ return (0L);
+@@ -1250,7 +1250,7 @@
+ tdestroy(cs->roots, free_root);
+ cs->roots = 0L;
+
+- dbus_connection_close(cs->connection);
++ dbus_connection_unref(cs->connection);
+ dbus_shutdown();
+ free(cs);
+ }
diff --git a/packages/dhcdbd/files/paths.patch b/packages/dhcdbd/files/paths.patch
new file mode 100644
index 0000000000..bf547d695c
--- /dev/null
+++ b/packages/dhcdbd/files/paths.patch
@@ -0,0 +1,25 @@
+--- a/include/dhcdbd.h.orig 2006-08-24 18:34:47.000000000 +0200
++++ b/include/dhcdbd.h 2006-09-28 19:48:59.000000000 +0200
+@@ -40,11 +40,11 @@
+ #endif
+
+ #ifndef DHCDBD_DHCLIENT_LEASE_DIR
+-#define DHCDBD_DHCLIENT_LEASE_DIR "/var/lib/dhclient/"
++#define DHCDBD_DHCLIENT_LEASE_DIR "/var/lib/dhcp/"
+ #endif
+
+ #ifndef DHCDBD_DHCLIENT_LEASE_PFX
+-#define DHCDBD_DHCLIENT_LEASE_PFX "dhclient-"
++#define DHCDBD_DHCLIENT_LEASE_PFX "dhclient."
+ #endif
+
+ #ifndef DHCDBD_DHCLIENT_LEASE_SFX
+@@ -56,7 +56,7 @@
+ #endif
+
+ #ifndef DHCDBD_DHCLIENT_PID_PFX
+-#define DHCDBD_DHCLIENT_PID_PFX "/var/run/dhclient-"
++#define DHCDBD_DHCLIENT_PID_PFX "/var/run/dhclient."
+ #endif
+
+ #ifndef DHCDBD_DHCLIENT_PID_SFX