aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dhcdbd
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-01-13 12:27:35 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2009-01-13 12:27:35 -0200
commit77e34a2586f1711868ee17ca89d9bd467cdac0b1 (patch)
treedb3d88ac52c2ab96237130d88709edd57ca65821 /packages/dhcdbd
parent44b7ac123a781091d48736931a9111f603e62577 (diff)
downloadopenembedded-77e34a2586f1711868ee17ca89d9bd467cdac0b1.tar.gz
dhcdbd: update 2.0 recipe to be in sync with new 3.0 one
Diffstat (limited to 'packages/dhcdbd')
-rw-r--r--packages/dhcdbd/dhcdbd_2.0.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/packages/dhcdbd/dhcdbd_2.0.bb b/packages/dhcdbd/dhcdbd_2.0.bb
index a1b6f321e1..8b5bf3bb83 100644
--- a/packages/dhcdbd/dhcdbd_2.0.bb
+++ b/packages/dhcdbd/dhcdbd_2.0.bb
@@ -3,11 +3,16 @@ SECTION = "net"
LICENSE = "GPL"
DEPENDS = "dbus"
RDEPENDS = "dhcp-client"
+PR = "r1"
SRC_URI = "http://dcantrel.fedorapeople.org/dhcdbd/dhcdbd-${PV}.tar.bz2 \
+ file://dbus_connection_unref.patch;patch=1 \
+ file://paths.patch;patch=1 \
file://no-ext-options.patch;patch=1 \
file://dhcdbd"
+inherit update-rc.d
+
do_compile() {
CC=${TARGET_SYS}-gcc DESTDIR=${prefix} make
}
@@ -18,4 +23,6 @@ do_install() {
install -m 0755 ${WORKDIR}/dhcdbd ${D}/etc/init.d/
}
+INITSCRIPT_NAME = dhcdbd
+INITSCRIPT_PARAMS = "start 30 2 3 4 5 . stop 30 0 1 6 ."
FILES_${PN} += "${sysconfdir} ${datadir}/dbus-1 ${base_sbindir}/*"