aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dhcdbd
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2006-08-24 16:21:25 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2006-08-24 16:21:25 +0000
commita4bbe9dd7f07b610bf275a1bce4829f18069f581 (patch)
tree91ec416e27d2aaa0be0ee380372023a2c6e32832 /packages/dhcdbd
parent4c8b88007468700648afff0a7b961e96b112e5ce (diff)
downloadopenembedded-a4bbe9dd7f07b610bf275a1bce4829f18069f581.tar.gz
dhcdbd: Add 1.14 by Milan Plzik
Diffstat (limited to 'packages/dhcdbd')
-rw-r--r--packages/dhcdbd/.mtn2git_empty0
-rw-r--r--packages/dhcdbd/dhcdbd_1.14.bb26
-rw-r--r--packages/dhcdbd/files/.mtn2git_empty0
-rwxr-xr-xpackages/dhcdbd/files/dhcdbd28
-rw-r--r--packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch26
5 files changed, 80 insertions, 0 deletions
diff --git a/packages/dhcdbd/.mtn2git_empty b/packages/dhcdbd/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dhcdbd/.mtn2git_empty
diff --git a/packages/dhcdbd/dhcdbd_1.14.bb b/packages/dhcdbd/dhcdbd_1.14.bb
new file mode 100644
index 0000000000..f46543d2d4
--- /dev/null
+++ b/packages/dhcdbd/dhcdbd_1.14.bb
@@ -0,0 +1,26 @@
+DESCRIPTION="DBus-enabled dhcp client"
+SECTION="net"
+LICENSE="GPL"
+HOMEPAGE="http://people.redhat.com/jvdias/dhcdbd/"
+MAINTAINER="Milan Plzik <mmp@handhelds.org>"
+
+DEPENDS = "dbus"
+
+SRC_URI="http://people.redhat.com/jvdias/dhcdbd/dhcdbd-${PV}.tar.gz \
+ file://dhcdbd-1.14-pkgconfig_dbus.patch;patch=1\
+ file://dhcdbd"
+
+do_configure() {
+}
+
+do_compile() {
+ CC=${TARGET_SYS}-gcc DESTDIR=${prefix} make
+}
+
+do_install() {
+ DESTDIR=${D} make install
+ install -d ${D}/etc/init.d
+ install -m 0755 ${WORKDIR}/dhcdbd ${D}/etc/init.d/
+}
+
+FILES_${PN}="${sysconfdir} ${datadir}/dbus-1 ${base_sbindir}"
diff --git a/packages/dhcdbd/files/.mtn2git_empty b/packages/dhcdbd/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dhcdbd/files/.mtn2git_empty
diff --git a/packages/dhcdbd/files/dhcdbd b/packages/dhcdbd/files/dhcdbd
new file mode 100755
index 0000000000..568753c28c
--- /dev/null
+++ b/packages/dhcdbd/files/dhcdbd
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+# DHCDBD startup script
+
+. /etc/profile
+
+case $1 in
+ 'start')
+ echo -n "Starting dhcdbd daemon: dhcdbd"
+ /sbin/dhcdbd --system
+ echo "."
+ ;;
+
+ 'stop')
+ echo -n "Stopping dhcdbd: dhcdbd"
+ killall `ps |grep /sbin/dhcdbd | grep -v grep | cut "-d " -f2`
+ echo "."
+ ;;
+
+ 'restart')
+ $0 stop
+ $0 start
+ ;;
+
+ *)
+ echo "Usage: $0 { start | stop | restart }"
+ ;;
+esac
diff --git a/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch b/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch
new file mode 100644
index 0000000000..c2e2151d17
--- /dev/null
+++ b/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch
@@ -0,0 +1,26 @@
+diff -Naur dhcdbd-1.14/Makefile dhcdbd-1.14-mod/Makefile
+--- dhcdbd-1.14/Makefile 2006-01-17 22:23:51.000000000 +0100
++++ dhcdbd-1.14-mod/Makefile 2006-08-02 18:02:42.000000000 +0200
+@@ -7,8 +7,8 @@
+ LDFLAGS ?= -g
+ DESTDIR ?= /
+ LIBDIR ?= lib
+-DBUS_INCLUDES ?= -I/usr/$(LIBDIR)/dbus-1.0/include -I/usr/include/dbus-1.0
+-DBUS_LIBS ?= -ldbus-1
++DBUS_INCLUDES ?= `pkg-config dbus-1 --cflags`
++DBUS_LIBS ?= `pkg-config dbus-1 --libs`
+ OBJS = dbus_service.o dhcdbd.o dhcp_options.o main.o
+ SRCS = dbus_service.c dhcdbd.c dhcp_options.c main.c
+ INCS = dbus_service.h dhcdbd.h dhcp_options.h includes.h
+diff -Naur dhcdbd-1.14/tests/Makefile dhcdbd-1.14-mod/tests/Makefile
+--- dhcdbd-1.14/tests/Makefile 2006-01-17 22:23:51.000000000 +0100
++++ dhcdbd-1.14-mod/tests/Makefile 2006-08-02 18:11:43.000000000 +0200
+@@ -2,7 +2,7 @@
+ LD = ${CC}
+ CFLAGS ?= -g -Wall
+ LDFLAGS ?= -g
+-DBUS_LIBS ?= -ldbus-1
++DBUS_LIBS ?= `pkg-config dbus-1 --libs`
+
+ all: test_dhcp_options test_dhcdbd_state test_subscriber test_subscriber_dbus test_prospective_subscriber
+