aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dhcp-forwarder
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/dhcp-forwarder
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/dhcp-forwarder')
-rw-r--r--packages/dhcp-forwarder/dhcp-forwarder_0.6.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/dhcp-forwarder/dhcp-forwarder_0.6.bb b/packages/dhcp-forwarder/dhcp-forwarder_0.6.bb
index e69de29bb2..6b61b8a1e3 100644
--- a/packages/dhcp-forwarder/dhcp-forwarder_0.6.bb
+++ b/packages/dhcp-forwarder/dhcp-forwarder_0.6.bb
@@ -0,0 +1,27 @@
+SECTION = "console/network"
+DESCRIPTION = "This program is used to forward DHCP and BOOTP messages between two \
+ networks with different broadcast domains. \
+ It works better with ppp - and especially with ipsec over ppp - than \
+ dhcp-relay from ISC and has a smaller foot print."
+HOMEPAGE = "http://www-user.tu-chemnitz.de/~ensc/dhcp-fwd/"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+LICENSE = "GPLv2"
+
+SRC_URI = "http://www-user.tu-chemnitz.de/~ensc/dhcp-fwd/files/dhcp-forwarder-0.6.tar.bz2 \
+ file://init \
+ file://dhcp-fwd.cfg"
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF="--disable-dietlibc"
+
+INITSCRIPT_NAME="dhcp-forwarder"
+INITSCRIPT_PARAMS="defaults"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/dhcp-forwarder
+ install -m 0644 ${WORKDIR}/dhcp-fwd.cfg ${D}/${sysconfdir}
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/dhcp-fwd.cfg"