aboutsummaryrefslogtreecommitdiffstats
path: root/packages/diffutils/diffutils_2.8.1.bb
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-10-15 02:11:45 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-10-15 02:11:45 +0000
commit96770840c270ff272c34a7df4050c7a2076d78a6 (patch)
treecbe49a42d2954779879d9797234abe7fc5543b44 /packages/diffutils/diffutils_2.8.1.bb
parentb6820e12f3e8eaccc180aa4dc4e681de6b1306a2 (diff)
downloadopenembedded-96770840c270ff272c34a7df4050c7a2076d78a6.tar.gz
diffutils 2.8.1: Use alternatives for diff since busybox also supplies a
diff command. As per #1472.
Diffstat (limited to 'packages/diffutils/diffutils_2.8.1.bb')
-rw-r--r--packages/diffutils/diffutils_2.8.1.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/packages/diffutils/diffutils_2.8.1.bb b/packages/diffutils/diffutils_2.8.1.bb
index e8de2cad62..a0a7b7dad9 100644
--- a/packages/diffutils/diffutils_2.8.1.bb
+++ b/packages/diffutils/diffutils_2.8.1.bb
@@ -3,11 +3,11 @@ LICENSE = "GPL"
DESCRIPTION = "Diffutils contains the GNU diff, diff3, \
sdiff, and cmp utilities. These programs are usually \
used for creating patch files."
-PR = "r1"
+PR = "r2"
SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz"
-inherit autotools
+inherit autotools update-alternatives
# diffutils assumes non-glibc compilation with uclibc and
# this causes it to generate its own implementations of
@@ -15,3 +15,11 @@ inherit autotools
# because it uses __mempcpy, there are other things (TBD:
# see diffutils.mk in buildroot)
EXTRA_OECONF_linux-uclibc = "--without-included-regex"
+
+do_install_append () {
+ mv ${D}${bindir}/diff ${D}${bindir}/diff.${PN}
+}
+
+ALTERNATIVE_NAME = "diff"
+ALTERNATIVE_PATH = "diff.${PN}"
+ALTERNATIVE_PRIORITY = "100"