aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dillo
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/dillo
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/dillo')
-rw-r--r--packages/dillo/dillo2_0.6.6.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/dillo/dillo2_0.6.6.bb b/packages/dillo/dillo2_0.6.6.bb
index e69de29bb2..c4fff54e23 100644
--- a/packages/dillo/dillo2_0.6.6.bb
+++ b/packages/dillo/dillo2_0.6.6.bb
@@ -0,0 +1,29 @@
+SECTION = "x11/network"
+DESCRIPTION = "Lightweight gtk+2 browser."
+LICENSE = "GPL"
+DEPENDS = "gtk+"
+RDEPENDS = "gdk-pixbuf-loader-xpm"
+SRC_URI="http://www.dillo.org/download/dillo-${PV}.tar.gz \
+ file://gtk2.patch;patch=1;pnum=1 \
+ file://fix_about_syntax.patch;patch=1;pnum=1 \
+ file://dillo.desktop \
+ file://dillo.png \
+ file://dillorc"
+
+MAINTAINER = "Chris Lord <cwiiis@handhelds.org>"
+PRIORITY = "optional"
+
+S = ${WORKDIR}/dillo-${PV}/
+
+inherit autotools pkgconfig
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install -d ${D}${datadir}/pixmaps
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/dillo.desktop ${D}${datadir}/applications/dillo.desktop
+ install -m 0644 ${WORKDIR}/dillo.png ${D}${datadir}/pixmaps/dillo.png
+ install -m 0755 ${S}/src/dillo ${D}${bindir}/dillo
+ install -m 0644 ${WORKDIR}/dillorc ${D}${sysconfdir}/dillorc
+}