aboutsummaryrefslogtreecommitdiffstats
path: root/packages/directfb/directfb_1.0.0.bb
diff options
context:
space:
mode:
authorShane Volpe <shanevolpe@gmail.com>2007-03-17 14:06:02 +0000
committerShane Volpe <shanevolpe@gmail.com>2007-03-17 14:06:02 +0000
commit539db2599c77eec1d6692935a20e240507da6c11 (patch)
treed5506ff906b12dede2117ce2a2232b5d36c1f2d0 /packages/directfb/directfb_1.0.0.bb
parent535f336152c3f10bffaa52e2526ff4cda299e44a (diff)
downloadopenembedded-539db2599c77eec1d6692935a20e240507da6c11.tar.gz
Directfb 1.0.0: Add 1.0.0 and delete RC3, update pkgconifg patch to fix all .pc.in files
Diffstat (limited to 'packages/directfb/directfb_1.0.0.bb')
-rw-r--r--packages/directfb/directfb_1.0.0.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/packages/directfb/directfb_1.0.0.bb b/packages/directfb/directfb_1.0.0.bb
new file mode 100644
index 0000000000..2e5dcbd086
--- /dev/null
+++ b/packages/directfb/directfb_1.0.0.bb
@@ -0,0 +1,48 @@
+DESCRIPTION = "DirectFB is a thin library that provides developers \
+with hardware graphics acceleration, input device handling and \
+abstraction, an integrated windowing system with support for \
+translucent windows and multiple display layers on top of the \
+Linux framebuffer device."
+SECTION = "libs"
+LICENSE = "LGPL"
+HOMEPAGE = "http://directfb.org"
+DEPENDS = "jpeg libpng freetype zlib tslib"
+PR = "r1"
+RV = "1.0-0"
+
+SRC_URI = "http://www.directfb.org/download/DirectFB/DirectFB-${PV}.tar.gz \
+ file://fix-pkgconfig-cflags.patch;patch=1 \
+ file://mkdfiff.patch;patch=1"
+
+S = "${WORKDIR}/DirectFB-1.0.0"
+
+LDFLAGS_append =" -lts -lm"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-gfxdrivers=none \
+ --enable-libmpeg3=no \
+ --enable-freetype=yes \
+ --enable-sdl=no \
+ "
+
+do_stage() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+FILES_directfb-dbg_append = " ${libdir}/directfb-${RV}/*/*/.debug/*.so \
+ ${libdir}/directfb-${RV}/*/.debug/*.so \
+ "
+
+FILES_directfb-dev_append = " ${libdir}/directfb-${RV}/systems/*.la \
+ ${libdir}/directfb-${RV}/inputdrivers/*.la \
+ ${libdir}/directfb-${RV}/interfaces/*/*.la \
+ ${libdir}/directfb-${RV}/wm/*.la"
+
+
+FILES_directfb_append = " ${libdir}/directfb-${RV}/systems/*.so \
+ ${libdir}/directfb-${RV}/inputdrivers/*.so \
+ ${libdir}/directfb-${RV}/interfaces/*/*.so \
+ ${libdir}/directfb-${RV}/wm/*.so \
+ ${datadir}/directfb-1.0.0 \
+ "