aboutsummaryrefslogtreecommitdiffstats
path: root/packages/directfb
diff options
context:
space:
mode:
authorShane Volpe <shanevolpe@gmail.com>2007-03-17 14:06:02 +0000
committerShane Volpe <shanevolpe@gmail.com>2007-03-17 14:06:02 +0000
commit539db2599c77eec1d6692935a20e240507da6c11 (patch)
treed5506ff906b12dede2117ce2a2232b5d36c1f2d0 /packages/directfb
parent535f336152c3f10bffaa52e2526ff4cda299e44a (diff)
downloadopenembedded-539db2599c77eec1d6692935a20e240507da6c11.tar.gz
Directfb 1.0.0: Add 1.0.0 and delete RC3, update pkgconifg patch to fix all .pc.in files
Diffstat (limited to 'packages/directfb')
-rw-r--r--packages/directfb/directfb_1.0.0.bb (renamed from packages/directfb/directfb_0.9.99+1.0.0rc3.bb)19
-rw-r--r--packages/directfb/files/fix-pkgconfig-specs.patch48
2 files changed, 49 insertions, 18 deletions
diff --git a/packages/directfb/directfb_0.9.99+1.0.0rc3.bb b/packages/directfb/directfb_1.0.0.bb
index 5bb6aa362e..2e5dcbd086 100644
--- a/packages/directfb/directfb_0.9.99+1.0.0rc3.bb
+++ b/packages/directfb/directfb_1.0.0.bb
@@ -10,24 +10,23 @@ DEPENDS = "jpeg libpng freetype zlib tslib"
PR = "r1"
RV = "1.0-0"
-SRC_URI = "http://www.directfb.org/download/DirectFB/DirectFB-1.0.0-rc3.tar.gz \
- file://fix-pkgconfig-specs.patch;patch=1 \
+SRC_URI = "http://www.directfb.org/download/DirectFB/DirectFB-${PV}.tar.gz \
+ file://fix-pkgconfig-cflags.patch;patch=1 \
file://mkdfiff.patch;patch=1"
-S = "${WORKDIR}/DirectFB-1.0.0-rc3"
+S = "${WORKDIR}/DirectFB-1.0.0"
LDFLAGS_append =" -lts -lm"
inherit autotools pkgconfig
-EXTRA_OECONF = "--with-gfxdrivers=none --enable-libmpeg3=no --enable-freetype=yes --enable-sdl=no"
-PARALLEL_MAKE = ""
+EXTRA_OECONF = "--with-gfxdrivers=none \
+ --enable-libmpeg3=no \
+ --enable-freetype=yes \
+ --enable-sdl=no \
+ "
do_stage() {
- autotools_stage_all
-}
-
-do_install() {
oe_runmake 'DESTDIR=${D}' install
}
@@ -45,5 +44,5 @@ FILES_directfb_append = " ${libdir}/directfb-${RV}/systems/*.so \
${libdir}/directfb-${RV}/inputdrivers/*.so \
${libdir}/directfb-${RV}/interfaces/*/*.so \
${libdir}/directfb-${RV}/wm/*.so \
- ${datadir}/directfb-1.0.0-rc3 \
+ ${datadir}/directfb-1.0.0 \
"
diff --git a/packages/directfb/files/fix-pkgconfig-specs.patch b/packages/directfb/files/fix-pkgconfig-specs.patch
index 401d7fa443..0273b58ec5 100644
--- a/packages/directfb/files/fix-pkgconfig-specs.patch
+++ b/packages/directfb/files/fix-pkgconfig-specs.patch
@@ -1,13 +1,45 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- DirectFB-0.9.25.1/directfb.pc.in~fix-pkgconfig-specs 2005-10-19 01:14:04.000000000 +0200
-+++ DirectFB-0.9.25.1/directfb.pc.in 2006-05-20 01:02:37.000000000 +0200
+diff -ur DirectFB-1.0.0~org/directfb-internal.pc.in DirectFB-1.0.0/directfb-internal.pc.in
+--- DirectFB-1.0.0~org/directfb-internal.pc.in 2003-07-04 13:30:22.000000000 -0400
++++ DirectFB-1.0.0/directfb-internal.pc.in 2007-03-16 22:34:17.000000000 -0400
+@@ -8,4 +8,4 @@
+ Description: Third party module support package for DirectFB.
+ Version: @VERSION@
+ Requires: directfb = @VERSION@
+-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
++Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}
+diff -ur DirectFB-1.0.0~org/directfb.pc.in DirectFB-1.0.0/directfb.pc.in
+--- DirectFB-1.0.0~org/directfb.pc.in 2004-08-04 12:28:20.000000000 -0400
++++ DirectFB-1.0.0/directfb.pc.in 2007-03-16 22:31:33.000000000 -0400
@@ -8,4 +8,4 @@
Version: @VERSION@
Requires: fusion direct
Libs: -L${libdir} -ldirectfb @THREADLIB@ @DYNLIB@ @ZLIB_LIBS@ @OSX_LIBS@
-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
-+Cflags: @THREADFLAGS@ -I${includedir}/directfb
++Cflags: @THREADFLAGS@ -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/direct/direct.pc.in DirectFB-1.0.0/lib/direct/direct.pc.in
+--- DirectFB-1.0.0~org/lib/direct/direct.pc.in 2005-11-23 09:18:59.000000000 -0500
++++ DirectFB-1.0.0/lib/direct/direct.pc.in 2007-03-16 22:32:13.000000000 -0400
+@@ -7,4 +7,4 @@
+ Description: DirectFB base development library
+ Version: @VERSION@
+ Libs: -L${libdir} -ldirect @THREADLIB@ @DYNLIB@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/fusion/fusion.pc.in DirectFB-1.0.0/lib/fusion/fusion.pc.in
+--- DirectFB-1.0.0~org/lib/fusion/fusion.pc.in 2004-05-19 07:30:56.000000000 -0400
++++ DirectFB-1.0.0/lib/fusion/fusion.pc.in 2007-03-16 22:32:34.000000000 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lfusion
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/voodoo/voodoo.pc.in DirectFB-1.0.0/lib/voodoo/voodoo.pc.in
+--- DirectFB-1.0.0~org/lib/voodoo/voodoo.pc.in 2004-05-19 07:31:28.000000000 -0400
++++ DirectFB-1.0.0/lib/voodoo/voodoo.pc.in 2007-03-16 22:32:55.000000000 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lvoodoo
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}