aboutsummaryrefslogtreecommitdiffstats
path: root/packages/directfb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/directfb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/directfb')
-rw-r--r--packages/directfb/.mtn2git_empty0
-rw-r--r--packages/directfb/directfb_0.9.22.bb32
2 files changed, 32 insertions, 0 deletions
diff --git a/packages/directfb/.mtn2git_empty b/packages/directfb/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/directfb/.mtn2git_empty
diff --git a/packages/directfb/directfb_0.9.22.bb b/packages/directfb/directfb_0.9.22.bb
index e69de29bb2..e117b90f44 100644
--- a/packages/directfb/directfb_0.9.22.bb
+++ b/packages/directfb/directfb_0.9.22.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "DirectFB is a thin library that provides developers \
+with hardware graphics acceleration, input device handling and \
+abstraction, an integrated windowing system with support for \
+translucent windows and multiple display layers on top of the \
+Linux framebuffer device."
+SECTION = "libs"
+LICENSE = "LGPL"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "jpeg libpng zlib"
+PR = "r0"
+
+SRC_URI = "http://www.directfb.org/download/DirectFB/DirectFB-${PV}.tar.gz"
+S = "${WORKDIR}/DirectFB-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-gfxdrivers=none --enable-libmpeg3=no --enable-freetype=no --enable-sdl=no"
+PARALLEL_MAKE = ""
+
+do_stage() {
+ oe_runmake 'DESTDIR=${STAGING_LIBDIR}/' install
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+FILES_directfb_append = " ${libdir}/directfb-${PV}/systems/*.so \
+ ${libdir}/directfb-${PV}/inputdrivers/*.so \
+ ${libdir}/directfb-${PV}/interfaces/*/*.so \
+ ${datadir}/directfb-${PV}"