aboutsummaryrefslogtreecommitdiffstats
path: root/packages/directfb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-05-13 22:57:51 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-13 22:57:51 +0000
commit5bd360c14dcb39f4cc58818538b62f5aa51ebadb (patch)
treefa692d85c58812766a02fa8e2820a7fd66f3a038 /packages/directfb
parentd525077ac27d0fd93215fd4e9dd3e132398c025b (diff)
downloadopenembedded-5bd360c14dcb39f4cc58818538b62f5aa51ebadb.tar.gz
directfb: add version 0.9.25.1
Diffstat (limited to 'packages/directfb')
-rw-r--r--packages/directfb/++dfb_0.9.23.bb30
-rw-r--r--packages/directfb/dfb++_0.9.23.bb30
-rw-r--r--packages/directfb/directfb_0.9.25.1.bb35
3 files changed, 95 insertions, 0 deletions
diff --git a/packages/directfb/++dfb_0.9.23.bb b/packages/directfb/++dfb_0.9.23.bb
new file mode 100644
index 0000000000..4574b8eb4c
--- /dev/null
+++ b/packages/directfb/++dfb_0.9.23.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "A C++ Wrapper for the directfb framebuffer library."
+HOMEPAGE = "http://directfb.org"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "directfb"
+LICENSE = "LGPL"
+
+# needs a g++4 patch
+BROKEN = "1"
+
+SRC_URI = "http://www.directfb.org/downloads/Extras/++DFB-${PV}.tar.gz"
+S = "${WORKDIR}/++DFB-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake -C include 'libdir=/lib' 'includedir=/include/dfb++' \
+ 'oldincludedir=/include' 'datadir=/share' \
+ 'DESTDIR=${STAGING_LIBDIR}/..' \
+ install-dfbppincludeHEADERS
+ oe_runmake -C dfb++ 'libdir=/lib' 'includedir=/include/dfb++' \
+ 'oldincludedir=/include' 'datadir=/share' \
+ 'DESTDIR=${STAGING_LIBDIR}/..' \
+ install-libLTLIBRARIES
+}
+
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
diff --git a/packages/directfb/dfb++_0.9.23.bb b/packages/directfb/dfb++_0.9.23.bb
new file mode 100644
index 0000000000..0e0772da94
--- /dev/null
+++ b/packages/directfb/dfb++_0.9.23.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "A C++ Wrapper for the directfb framebuffer library."
+HOMEPAGE = "http://directfb.org"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "directfb"
+LICENSE = "LGPL"
+
+# needs a g++4 patch
+BROKEN = "1"
+
+SRC_URI = "http://www.directfb.org/downloads/Extras/DFB++-${PV}.tar.gz"
+S = "${WORKDIR}/DFB++-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake -C include 'libdir=/lib' 'includedir=/include/dfb++' \
+ 'oldincludedir=/include' 'datadir=/share' \
+ 'DESTDIR=${STAGING_LIBDIR}/..' \
+ install-dfbppincludeHEADERS
+ oe_runmake -C dfb++ 'libdir=/lib' 'includedir=/include/dfb++' \
+ 'oldincludedir=/include' 'datadir=/share' \
+ 'DESTDIR=${STAGING_LIBDIR}/..' \
+ install-libLTLIBRARIES
+}
+
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
diff --git a/packages/directfb/directfb_0.9.25.1.bb b/packages/directfb/directfb_0.9.25.1.bb
new file mode 100644
index 0000000000..7a54f3f304
--- /dev/null
+++ b/packages/directfb/directfb_0.9.25.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "DirectFB is a thin library that provides developers \
+with hardware graphics acceleration, input device handling and \
+abstraction, an integrated windowing system with support for \
+translucent windows and multiple display layers on top of the \
+Linux framebuffer device."
+SECTION = "libs"
+LICENSE = "LGPL"
+PRIORITY = "optional"
+HOMEPAGE = "http://directfb.org"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "jpeg libpng freetype zlib"
+PR = "r0"
+RV = "0.9.25"
+
+SRC_URI = "http://directfb.org/downloads/Core/DirectFB-${PV}.tar.gz"
+S = "${WORKDIR}/DirectFB-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-gfxdrivers=none --enable-libmpeg3=no --enable-freetype=yes --enable-sdl=no"
+PARALLEL_MAKE = ""
+
+do_stage() {
+ oe_runmake 'DESTDIR=${STAGING_LIBDIR}/' install
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+FILES_directfb_append = " ${libdir}/directfb-${RV}/systems/*.so \
+ ${libdir}/directfb-${RV}/inputdrivers/*.so \
+ ${libdir}/directfb-${RV}/interfaces/*/*.so \
+ ${libdir}/directfb-${RV}/wm/*.so \
+ ${datadir}/directfb-${RV}"