aboutsummaryrefslogtreecommitdiffstats
path: root/packages/docbook-sgml-dtd
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-01-03 01:00:17 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-01-03 01:00:17 +0000
commitafb011e6080e2e41108ec6b0530a102de6765e83 (patch)
tree6a9df538b92ade41a539870f22988756a99207fb /packages/docbook-sgml-dtd
parentef3e342cf7d4a74e84836f07193463f72bac264c (diff)
downloadopenembedded-afb011e6080e2e41108ec6b0530a102de6765e83.tar.gz
docbook-sgml-dtd-native: Simplified and added new versions 4.1 and 4.4
sgmlspl: New recipe. docbook-utils-native: Adjusted dependencies and added sgmlspl.
Diffstat (limited to 'packages/docbook-sgml-dtd')
-rw-r--r--packages/docbook-sgml-dtd/docbook-sgml-dtd-3.1-native.bb12
-rw-r--r--packages/docbook-sgml-dtd/docbook-sgml-dtd-4.1-native.bb12
-rw-r--r--packages/docbook-sgml-dtd/docbook-sgml-dtd-4.4-native.bb10
-rw-r--r--packages/docbook-sgml-dtd/docbook-sgml-dtd-native.inc (renamed from packages/docbook-sgml-dtd/docbook-sgml-dtd-native_3.1.bb)28
4 files changed, 49 insertions, 13 deletions
diff --git a/packages/docbook-sgml-dtd/docbook-sgml-dtd-3.1-native.bb b/packages/docbook-sgml-dtd/docbook-sgml-dtd-3.1-native.bb
new file mode 100644
index 0000000000..4b0e4629b8
--- /dev/null
+++ b/packages/docbook-sgml-dtd/docbook-sgml-dtd-3.1-native.bb
@@ -0,0 +1,12 @@
+require docbook-sgml-dtd-native.inc
+
+DTD_VERSION = "3.1"
+
+SRC_URI = "http://www.docbook.org/sgml/3.1/docbk31.zip;md5sum=432749c0c806dbae81c8bcb70da3b5d3"
+
+do_compile() {
+ # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/sgml-dtd-3.html
+ # for details.
+ sed -i -e '/ISO 8879/d' -e 's|DTDDECL "-//OASIS//DTD DocBook V3.1//EN"|SGMLDECL|g' docbook.cat
+}
+
diff --git a/packages/docbook-sgml-dtd/docbook-sgml-dtd-4.1-native.bb b/packages/docbook-sgml-dtd/docbook-sgml-dtd-4.1-native.bb
new file mode 100644
index 0000000000..bd75d6ad68
--- /dev/null
+++ b/packages/docbook-sgml-dtd/docbook-sgml-dtd-4.1-native.bb
@@ -0,0 +1,12 @@
+require docbook-sgml-dtd-native.inc
+
+DTD_VERSION = "4.1"
+
+SRC_URI = "http://docbook.org/sgml/4.1/docbk41.zip"
+
+do_compile() {
+ # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/sgml-dtd.html
+ # for details.
+ sed -i -e '/ISO 8879/d' -e '/gml/d' docbook.cat
+}
+
diff --git a/packages/docbook-sgml-dtd/docbook-sgml-dtd-4.4-native.bb b/packages/docbook-sgml-dtd/docbook-sgml-dtd-4.4-native.bb
new file mode 100644
index 0000000000..4ff48b7940
--- /dev/null
+++ b/packages/docbook-sgml-dtd/docbook-sgml-dtd-4.4-native.bb
@@ -0,0 +1,10 @@
+require docbook-sgml-dtd-native.inc
+
+DTD_VERSION = "4.4"
+
+do_compile() {
+ # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/sgml-dtd.html
+ # for details.
+ sed -i -e '/ISO 8879/d' -e '/gml/d' docbook.cat
+}
+
diff --git a/packages/docbook-sgml-dtd/docbook-sgml-dtd-native_3.1.bb b/packages/docbook-sgml-dtd/docbook-sgml-dtd-native.inc
index 926c311fd5..69c9811d8a 100644
--- a/packages/docbook-sgml-dtd/docbook-sgml-dtd-native_3.1.bb
+++ b/packages/docbook-sgml-dtd/docbook-sgml-dtd-native.inc
@@ -1,29 +1,31 @@
+# The DTDs of the various versions have to be installed in parallel and should
+# not replace each other. The installation step is common for all versions
+# and just differs in the DTD_VERSION.
+#
+# However the DTDs need some quirks (see LFS documentation).
+
DESCRIPTION = "Document type definitions for verification of SGML data files against the DocBook rule set"
DEPENDS = "sgml-common-native"
-SRC_URI = "http://www.docbook.org/sgml/${PV}/docbk31.zip"
+SRC_URI = "http://www.docbook.org/sgml/${DTD_VERSION}/docbook-${DTD_VERSION}.zip"
S = "${WORKDIR}"
inherit native
-do_compile() {
- sed -i -e '/ISO 8879/d' -e 's|DTDDECL "-//OASIS//DTD DocBook V3.1//EN"|SGMLDECL|g' docbook.cat
-}
-
do_stage () {
- # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/sgml-dtd-3.html
+ # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/sgml-dtd.html
# for details.
- install -d -m 755 ${STAGING_DATADIR}/sgml/docbook/sgml-dtd-${PV}
- install docbook.cat ${STAGING_DATADIR}/sgml/docbook/sgml-dtd-${PV}/catalog
- cp -dpr *.dtd *.mod *.dcl ${STAGING_DATADIR}/sgml/docbook/sgml-dtd-${PV}
+ install -d -m 755 ${STAGING_DATADIR}/sgml/docbook/sgml-dtd-${DTD_VERSION}
+ install docbook.cat ${STAGING_DATADIR}/sgml/docbook/sgml-dtd-${DTD_VERSION}/catalog
+ cp -dpr *.dtd *.mod *.dcl ${STAGING_DATADIR}/sgml/docbook/sgml-dtd-${DTD_VERSION}
- install-catalog --add ${sysconfdir}/sgml/sgml-docbook-dtd-${PV}.cat \
- ${STAGING_DATADIR}/sgml/docbook/sgml-dtd-${PV}/catalog
+ install-catalog --add ${sysconfdir}/sgml/sgml-docbook-dtd-${DTD_VERSION}.cat \
+ ${STAGING_DATADIR}/sgml/docbook/sgml-dtd-${DTD_VERSION}/catalog
- install-catalog --add ${sysconfdir}/sgml/sgml-docbook-dtd-${PV}.cat \
- ${sysconfdir}/sgml/sgml-docbook.cat
+ install-catalog --add ${sysconfdir}/sgml/sgml-docbook-dtd-${DTD_VERSION}.cat \
+ ${sysconfdir}/sgml/sgml-docbook.cat
}
PACKAGES = ""