aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dreambox/dreambox-secondstage.bb
diff options
context:
space:
mode:
authorFelix Domke <tmbinc@elitedvb.ne>2008-02-27 00:12:05 +0000
committerFelix Domke <tmbinc@elitedvb.ne>2008-02-27 00:12:05 +0000
commitd9cbd721571d560a5464d89bba425d05c4955584 (patch)
tree68fdf8725d16b7db3a7e2f51c28972e3df542302 /packages/dreambox/dreambox-secondstage.bb
parentca6c9cb48b2a804f682eb865fde9e6d190accea0 (diff)
downloadopenembedded-d9cbd721571d560a5464d89bba425d05c4955584.tar.gz
dreambox-secondstage: dm8000,dm800 support
Diffstat (limited to 'packages/dreambox/dreambox-secondstage.bb')
-rw-r--r--packages/dreambox/dreambox-secondstage.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/packages/dreambox/dreambox-secondstage.bb b/packages/dreambox/dreambox-secondstage.bb
index 4aff7cbee2..7ac1a76184 100644
--- a/packages/dreambox/dreambox-secondstage.bb
+++ b/packages/dreambox/dreambox-secondstage.bb
@@ -6,6 +6,8 @@ PV_dm7020 = "35"
PV_dm7025 = "51"
PV_dm600pvr = "53"
PV_dm500plus = "53"
+PV_dm8000 = "53"
+PV_dm800 = "57"
PR = "r0"
SRC_URI = "http://sources.dreamboxupdate.com/download/7020/secondstage-${MACHINE}-${PV}.bin"
@@ -16,3 +18,9 @@ do_stage() {
install -d ${STAGING_LIBDIR}/dreambox-secondstage
gzip -c ${S}/secondstage-${MACHINE}-${PV}.bin > ${STAGING_LIBDIR}/dreambox-secondstage/main.bin.gz
}
+
+# the dm800 secondstage is already compressed (and encrypted)
+do_stage_dm800() {
+ install -d ${STAGING_LIBDIR}/dreambox-secondstage
+ cp ${S}/secondstage-${MACHINE}-${PV}.bin ${STAGING_LIBDIR}/dreambox-secondstage/main.bin.gz
+}