aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dreambox/dreambox-secondstage.bb
diff options
context:
space:
mode:
authorFelix Domke <tmbinc@elitedvb.ne>2005-09-20 23:31:06 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-20 23:31:06 +0000
commitee85b3cb291c8bcb733fd889c2cdd6ea9c141a41 (patch)
treef4a41102c35befe57470b6f60414847229fcc71b /packages/dreambox/dreambox-secondstage.bb
parent3f24cdd7fd3ec5b8b8e79f98a3df61c4c46feff6 (diff)
downloadopenembedded-ee85b3cb291c8bcb733fd889c2cdd6ea9c141a41.tar.gz
dreambox-secondstage: support other machines (dm7020 and dm7025 for now)
Diffstat (limited to 'packages/dreambox/dreambox-secondstage.bb')
-rw-r--r--packages/dreambox/dreambox-secondstage.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/packages/dreambox/dreambox-secondstage.bb b/packages/dreambox/dreambox-secondstage.bb
index 0edbdda80e..0db7e823c2 100644
--- a/packages/dreambox/dreambox-secondstage.bb
+++ b/packages/dreambox/dreambox-secondstage.bb
@@ -1,16 +1,17 @@
-DESCRIPTION = "Dreambox DM7020 second stage bootloader"
+DESCRIPTION = "Dreambox DM702x second stage bootloader"
SECTION = "base"
PRIORITY = "required"
MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
-PV = "28"
+PV_dm7020 = "28"
+PV_dm7025 = "35"
PR = "r0"
-SRC_URI = "http://sources.dreamboxupdate.com/download/7020/secondstage-${PV}-${PR}.bin"
+SRC_URI = "http://sources.dreamboxupdate.com/download/7020/secondstage-${MACHINE}-${PV}.bin"
S = "${WORKDIR}"
do_stage() {
install -d ${STAGING_LIBDIR}/dreambox-secondstage
- gzip -c ${S}/secondstage-${PV}-${PR}.bin > ${STAGING_LIBDIR}/dreambox-secondstage/main.bin.gz
+ gzip -c ${S}/secondstage-${MACHINE}-${PV}.bin > ${STAGING_LIBDIR}/dreambox-secondstage/main.bin.gz
}