aboutsummaryrefslogtreecommitdiffstats
path: root/packages/driftnet
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-09-10 15:51:47 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-10 15:51:47 +0000
commit5e895c3b0f7dd2c39df036fac15d08632161a66f (patch)
tree93d2819feabf45f9d97e35a8a7ea14377170b435 /packages/driftnet
parenta8333ac3fbf2d2890e329502ce0f3d027f6ef173 (diff)
downloadopenembedded-5e895c3b0f7dd2c39df036fac15d08632161a66f.tar.gz
packages/driftnet/driftnet-nogui_0.1.6.bb: add the nogui version, courtesy Simon Pickering, closes #318
Diffstat (limited to 'packages/driftnet')
-rw-r--r--packages/driftnet/driftnet-nogui_0.1.6.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/driftnet/driftnet-nogui_0.1.6.bb b/packages/driftnet/driftnet-nogui_0.1.6.bb
new file mode 100644
index 0000000000..f17d5b99ce
--- /dev/null
+++ b/packages/driftnet/driftnet-nogui_0.1.6.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Driftnet watches network traffic, and picks out and displays JPEG and GIF \
+images for display. It is an horrific invasion of privacy and shouldn't be used \
+by anyone anywhere. It can also extract MPEG audio data from the network and \
+play it."
+MAINTAINER = "Simon Pickering <S.G.Pickering@bath.ac.uk>"
+SECTION = "net"
+PRIORITY = "optional"
+
+DEPENDS = "libpcap jpeg libungif"
+PV = "0.1.6"
+
+SRC_URI = "http://www.ex-parrot.com/~chris/driftnet/driftnet-${PV}.tar.gz \
+ file://arm.patch;patch=1"
+
+S = "${WORKDIR}/driftnet-${PV}"
+
+inherit autotools
+
+do_compile() {
+ oe_runmake STAGING_INCDIR="${STAGING_INCDIR}"
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0744 driftnet ${D}/${bindir}/
+}