aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dsplink
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-10-23 08:52:31 +0200
committerKoen Kooi <koen@openembedded.org>2008-10-23 08:52:31 +0200
commit7ce959da11d87ace501005d4f8210a34413443ff (patch)
tree2984c8618edfbae6928ad8fedad235b85c1a7141 /packages/dsplink
parentd40f6e14fbd370672b111b4216f9736bae969d5b (diff)
downloadopenembedded-7ce959da11d87ace501005d4f8210a34413443ff.tar.gz
dsplink: cleanups
* remove old recipes * make dsplink configure work with davinci as well * get rid of unneeded vars
Diffstat (limited to 'packages/dsplink')
-rw-r--r--packages/dsplink/dsplink-1.51/prcs-fix-include.patch29
-rw-r--r--packages/dsplink/dsplink.inc44
-rw-r--r--packages/dsplink/dsplink_1.50.bb24
-rw-r--r--packages/dsplink/dsplink_1.51.00.08.bb28
-rw-r--r--packages/dsplink/dsplink_1.60.00.04.bb4
5 files changed, 13 insertions, 116 deletions
diff --git a/packages/dsplink/dsplink-1.51/prcs-fix-include.patch b/packages/dsplink/dsplink-1.51/prcs-fix-include.patch
deleted file mode 100644
index a71cea3904..0000000000
--- a/packages/dsplink/dsplink-1.51/prcs-fix-include.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- /tmp/prcs.c 2008-05-15 20:35:49.946802023 +0200
-+++ dsplink_1_50/dsplink/gpp/src/osal/Linux/prcs.c 2008-05-15 20:36:01.386858569 +0200
-@@ -17,6 +17,7 @@
-
- /* ----------------------------------- OS Specific Headers */
- #include <linux/autoconf.h>
-+#include <linux/sched.h>
- #include <linux/spinlock.h>
- #include <linux/module.h>
- #include <linux/mm.h>
-
---- /tmp/mem.c 2008-06-22 16:05:16.000000000 +0200
-+++ dsplink_1_50/dsplink/gpp/src/osal/Linux/2.6.18/mem.c 2008-06-22 16:05:43.000000000 +0200
-@@ -16,6 +16,7 @@
-
-
- /* ----------------------------------- OS Specific Headers */
-+
- #include <linux/autoconf.h>
- #include <linux/spinlock.h>
- #if (defined(DM642_PCI) || defined (DM64LC_PCI))
-@@ -31,6 +32,7 @@
- #endif /* if (defined(DM642_PCI) || defined (DM64LC_PCI)) */
- #include <linux/vmalloc.h>
- #include <asm/io.h>
-+#include <linux/sched.h>
-
- /* ----------------------------------- DSP/BIOS Link */
- #include <dsplink.h>
diff --git a/packages/dsplink/dsplink.inc b/packages/dsplink/dsplink.inc
index 3b18d490cd..7c8d5c8baf 100644
--- a/packages/dsplink/dsplink.inc
+++ b/packages/dsplink/dsplink.inc
@@ -13,53 +13,33 @@ export DSPLINK = "${S}"
require ti-paths.inc
-DSPLINKPLATFORM ?= "Davinci"
-
+DSPLINKPLATFORM ?= "DAVINCI"
DSPLINKPLATFORM_omap5912osk = "OMAP"
DSPLINKPLATFORM_beagleboard = "OMAP3530"
-DSPLINKPLATFORM_davinci-sffsdr = "Davinci"
-DSPLINKPLATFORM_davinci-dvevm = "Davinci"
+DSPLINKPLATFORM_davinci-sffsdr = "DAVINCI"
+DSPLINKPLATFORM_davinci-dvevm = "DAVINCI"
DSPLINKDSP ?= "C64XX"
-DSPLINKSOC ?= "DM6446"
+DSPLINKSOC ?= "DM6446"
DSPLINKSOC_beagleboard = "3530"
+DSPCFG ?= "DM6446GEMSHMEM"
+DSPCFG_beagleboard ?= "OMAP3530SHMEM"
-USERARMFLAGS = "${TARGET_CC_ARCH}"
-KERNELARMFLAGS = "-include linux/autoconf.h -c -iwithprefix include -Iinclude -Wall -Wstrict-prototypes \
- -Wno-trigraphs -fno-strict-aliasing -fno-common \
- -fno-omit-frame-pointer -mapcs -mno-sched-prolog \
- -mlittle-endian \
- -D__LINUX_ARM_ARCH__=5 -march=armv5t -mtune=arm9tdmi \
- -Uarm \
- -Wdeclaration-after-statement -Os -marm -mabi=aapcs-linux"
-KERNELARMFLAGS_armv6 = "-include linux/autoconf.h -c -iwithprefix include -Iinclude -Wall -Wstrict-prototypes \
- -Wno-trigraphs -fno-strict-aliasing -fno-common \
- -fno-omit-frame-pointer -mapcs -mno-sched-prolog \
- -mlittle-endian \
- -D__LINUX_ARM_ARCH__=6 -march=armv6j -mtune=arm1136jf-s \
- -Uarm \
- -Wdeclaration-after-statement -Os -marm -mabi=aapcs-linux"
-KERNELARMFLAGS_armv7a = "-c -nostdinc -include $(BASE_OSINC)/linux/autoconf.h -isystem $(OSINC_PLATFORM) -iwithprefix include -Iinclude -Wall -Wstrict-prototypes \
- -Wno-trigraphs -fno-strict-aliasing -fno-common \
- -fno-omit-frame-pointer -mapcs -mno-sched-prolog \
- -mlittle-endian \
- -D__LINUX_ARM_ARCH__=7 -march=armv7-a -mtune=cortex-a8 \
- -Uarm \
- -Wdeclaration-after-statement -Os -marm -mabi=aapcs-linux \
- -D__KERNEL__ -mno-thumb-interwork -msoft-float -fno-optimize-sibling-calls -g -fno-stack-protector -Wno-pointer-sign -g -DUSE_UDEV=1 -DOS_LINUX -DLINUX_KERNEL"
-
-DSPFLAGS = "-q -pdr -pdv -pden -ml3 -mv64+ "
+GPPOS ?= "DAVINCILSP"
+GPPOS_beagleboard = "OMAPLSP"
export DSPLINKPLATFORM
export DSPLINKDSP
export DSPLINKSOC
+export DSPCFG
+export GPPOS
do_configure () {
# Run perl script to create appropriate makefiles (v1.60 and up)
-DSPLINK=${S} perl config/bin/dsplinkcfg.pl --platform=${DSPLINKPLATFORM} --nodsp=1 --dspcfg_0=OMAP3530SHMEM --dspos_0=DSPBIOS5XX --gppos=OMAPLSP --comps=ponslrmc
+DSPLINK=${S} perl config/bin/dsplinkcfg.pl --platform=${DSPLINKPLATFORM} --nodsp=1 --dspcfg_0=${DSPCFG} --dspos_0=DSPBIOS5XX --gppos=${GPPOS} --comps=ponslrm
}
@@ -93,7 +73,7 @@ do_install () {
cp ${S}/gpp/BUILD/EXPORT/RELEASE/dsplinkk.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/
install -d ${D}/${bindir}
- install ${S}/gpp/BUILD/EXPORT/RELEASE/loopgpp ${D}/${bindir}
+# install ${S}/gpp/BUILD/EXPORT/RELEASE/loopgpp ${D}/${bindir}
install ${S}/gpp/BUILD/EXPORT/RELEASE/messagegpp ${D}/${bindir}
install ${S}/gpp/BUILD/EXPORT/RELEASE/messagemultigpp ${D}/${bindir}
install ${S}/gpp/BUILD/EXPORT/RELEASE/mpcsxfergpp ${D}/${bindir}
diff --git a/packages/dsplink/dsplink_1.50.bb b/packages/dsplink/dsplink_1.50.bb
deleted file mode 100644
index 62a352e43c..0000000000
--- a/packages/dsplink/dsplink_1.50.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-require dsplink.inc
-
-PR = "r10"
-PE = "1"
-PV = "1.50"
-
-# Get dsplink tarball from TI website, place in sources and calculate
-# md5sum
-# Look for tarball at https://www-a.ti.com/downloads/sds_support/targetcontent/link/index.html
-
-SRC_URI = "http://install.tarball.in.source.dir/dsplink_1_50.tar.gz \
- file://CURRENTCFG.MK \
- file://c64xx_5.xx_linux.mk \
- file://openembedded.mk \
- file://prcs-fix-include.patch;patch=1;pnum=2 \
-"
-
-SRC_URI_append_davinci-sffsdr = " \
- file://dsplink-128M.patch;patch=1;pnum=2 \
-"
-
-S = "${WORKDIR}/dsplink_1_50/dsplink"
-
-
diff --git a/packages/dsplink/dsplink_1.51.00.08.bb b/packages/dsplink/dsplink_1.51.00.08.bb
deleted file mode 100644
index 3c6d39e6c9..0000000000
--- a/packages/dsplink/dsplink_1.51.00.08.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-require dsplink.inc
-
-
-DEFAULT_PREFERENCE = "-1"
-DEFAULT_PREFERENCE_armv7a = "1"
-
-PR = "r10"
-PE = "1"
-PV = "1.51"
-
-# Get dsplink tarball from TI website, place in sources and calculate
-# md5sum
-# Look for tarball at https://www-a.ti.com/downloads/sds_support/targetcontent/link/index.html
-
-SRC_URI = "http://install.tarball.in.source.dir/dsplink_1_51_00_08.tar.gz \
- file://CURRENTCFG.MK \
- file://c64xx_5.xx_linux.mk \
- file://openembedded.mk \
- file://prcs-fix-include.patch;patch=1;pnum=2 \
- file://Makefile.dsplink \
-"
-
-SRC_URI_append_beagleboard = " \
-# file://dsplink-128M.patch;patch=1;pnum=2 \
-"
-
-S = "${WORKDIR}/dsplink_1_51_00_08/dsplink"
-
diff --git a/packages/dsplink/dsplink_1.60.00.04.bb b/packages/dsplink/dsplink_1.60.00.04.bb
index 2e0de85b58..b15e6022f1 100644
--- a/packages/dsplink/dsplink_1.60.00.04.bb
+++ b/packages/dsplink/dsplink_1.60.00.04.bb
@@ -1,11 +1,9 @@
require dsplink.inc
-
-DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_armv7a = "1"
# The tconf tool breaks if there is a '.' in your pwd
-PR = "r0"
+PR = "r1"
PE = "1"
PV = "160"