aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dsplink
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-11-19 16:25:39 +0100
committerKoen Kooi <koen@openembedded.org>2008-11-19 16:25:39 +0100
commita021f55580c68f6bf88393111ece7f14007b7b09 (patch)
treec5fb09bb2e71e0b52eb967b2c5a85f1b2113949d /packages/dsplink
parentc2b3a79ce8c90cb51cc4b1be3bfd7facd5970e77 (diff)
downloadopenembedded-a021f55580c68f6bf88393111ece7f14007b7b09.tar.gz
dsplink: remove damage done by git
* what tool stores inline conflicts in files in this day and age!?
Diffstat (limited to 'packages/dsplink')
-rw-r--r--packages/dsplink/dsplink.inc15
1 files changed, 15 insertions, 0 deletions
diff --git a/packages/dsplink/dsplink.inc b/packages/dsplink/dsplink.inc
index 1f72d24f92..c102e14c5e 100644
--- a/packages/dsplink/dsplink.inc
+++ b/packages/dsplink/dsplink.inc
@@ -47,6 +47,21 @@ do_compile () {
make -e -f ${WORKDIR}/Makefile.dsplink
}
+dsplink-kbuild-compile() {
+ mkdir -p ${S}/dsplink-kbuild-test
+ cp ${WORKDIR}/Makefile-dsplink-kbuild ${S}/dsplink-kbuild-test/Makefile
+ cd ${S}/dsplink-kbuild-test/
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \
+ KERNEL_SRC=${STAGING_KERNEL_DIR} \
+ KDIR=${STAGING_KERNEL_DIR} \
+ KERNEL_VERSION=${KERNEL_VERSION} \
+ CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
+ AR="${KERNEL_AR}" \
+ V=1 ${MAKE_TARGETS}
+
+}
+
do_install () {
install -d ${D}/${bindir}
# install ${S}/gpp/BUILD/EXPORT/RELEASE/loopgpp ${D}/${bindir}