aboutsummaryrefslogtreecommitdiffstats
path: root/packages/e17
diff options
context:
space:
mode:
authorCarsten Haitzler (Raster <raster@rasterman.com>2008-10-30 14:23:06 +1100
committerStefan Schmidt <stefan@datenfreihafen.org>2008-11-13 23:32:38 +0000
commitdcc6fbead960522b68f12392e1e7f0009af38b17 (patch)
tree5d215f39379f0a943892605b571a29e4e62785e1 /packages/e17
parent36705acbf8dfc65a9ce0652514cb0ee59cd456a4 (diff)
downloadopenembedded-dcc6fbead960522b68f12392e1e7f0009af38b17.tar.gz
e17+efl: update to match latest additions and changes upstream
lots of changes: 1. eina added. now a dependency. 2. illume removed as separate source tree and module and part of e17's wm 3. e17's default theme now include illume support so no need for illume theme these are fairly major but clean things up a lot. the e17 package splits out config profile now (it includes all of them as recommends though). the user can choose what profiel they want runtime. this is a "first time you run e" thing or whenever you choose the default profile (you go back to the wizard). also full intl support works with language selection etc. as long as glibc has that locale support. lots of other bugfixes and improvements as well. if you want "latest e+efl to work well" you will want these changes.
Diffstat (limited to 'packages/e17')
-rw-r--r--packages/e17/e-wm_svn.bb85
-rw-r--r--packages/e17/illume-theme-illume_svn.bb33
2 files changed, 74 insertions, 44 deletions
diff --git a/packages/e17/e-wm_svn.bb b/packages/e17/e-wm_svn.bb
index acbee85a70..a641a2c34a 100644
--- a/packages/e17/e-wm_svn.bb
+++ b/packages/e17/e-wm_svn.bb
@@ -2,11 +2,51 @@ DESCRIPTION = "The Enlightenment Window Manager Version 17"
DEPENDS = "eet evas ecore edje efreet edbus"
LICENSE = "MIT BSD"
PV = "0.16.999.043+svnr${SRCREV}"
-PR = "r15"
+PR = "r16"
inherit e update-alternatives
-RDEPENDS += "shared-mime-info mime-support"
+RDEPENDS += "shared-mime-info mime-support edje-utils glibc-utils"
+
+PACKAGES =+ "\
+ ${PN}-config-default \
+ ${PN}-config-illume \
+ ${PN}-config-minimalist \
+ ${PN}-config-netbook \
+ ${PN}-config-scaleable \
+ ${PN}-config-standard \
+ ${PN}-theme-default \
+ ${PN}-theme-illume \
+ ${PN}-background-dark-gradient \
+ ${PN}-background-light-gradient \
+ ${PN}-images \
+ ${PN}-icons \
+ ${PN}-other \
+ ${PN}-input-methods \
+"
+
+RRECOMMENDS_${PN} = "\
+ ${PN}-config-default \
+ ${PN}-images \
+ ${PN}-icons \
+ ${PN}-other \
+ ${PN}-input-methods \
+"
+
+PACKAGE_ARCH_${PN}-config-default = "all"
+PACKAGE_ARCH_${PN}-config-illume = "all"
+PACKAGE_ARCH_${PN}-config-minimalist = "all"
+PACKAGE_ARCH_${PN}-config-netbook = "all"
+PACKAGE_ARCH_${PN}-config-scaleable = "all"
+PACKAGE_ARCH_${PN}-config-standard = "all"
+PACKAGE_ARCH_${PN}-theme-default = "all"
+PACKAGE_ARCH_${PN}-theme-illume = "all"
+PACKAGE_ARCH_${PN}-background-dark-gradient = "all"
+PACKAGE_ARCH_${PN}-background-light-gradient = "all"
+PACKAGE_ARCH_${PN}-images = "all"
+PACKAGE_ARCH_${PN}-icons = "all"
+PACKAGE_ARCH_${PN}-other = "all"
+PACKAGE_ARCH_${PN}-input-methods = "all"
SRC_URI = "\
svn://svn.enlightenment.org/svn/e/trunk;module=e;proto=http \
@@ -37,30 +77,53 @@ do_stage() {
do_install_append() {
# customising - should rather make this simple upstream
- rm -rf ${D}${datadir}/enlightenment/data/backgrounds/*
- rm -rf ${D}${datadir}/enlightenment/data/fonts/*
- rm -rf ${D}${datadir}/enlightenment/data/other/*
install -m 755 ${WORKDIR}/enlightenment_start.oe ${D}/${bindir}
install -d ${D}/${sysconfdir}/xdg/menus
install -m 644 ${WORKDIR}/applications.menu ${D}/${sysconfdir}/xdg/menus/
+ for I in `find ${D}/${libdir}/enlightenment -name "*.a" -print`; do rm -f $I; done
+ for I in `find ${D}/${libdir}/enlightenment -name "*.la" -print`; do rm -f $I; done
}
FILES_${PN} = "\
${bindir}/* \
${libdir}/enlightenment/modules/*/*.* \
${libdir}/enlightenment/modules/*/*/* \
- ${libdir}/enlightenment/preload/*.so \
- ${datadir} \
+ ${datadir}/locale \
+ ${datadir}/enlightenment/data/icons \
+ ${datadir}/enlightenment/data/input_methods \
+ ${datadir}/enlightenment/data/config/profile.cfg \
${sysconfdir} \
"
+FILES_${PN}-config-default = "${datadir}/enlightenment/data/config/default"
+FILES_${PN}-config-illume = "${datadir}/enlightenment/data/config/illume"
+FILES_${PN}-config-minimalist = "${datadir}/enlightenment/data/config/minimalist"
+FILES_${PN}-config-netbook = "${datadir}/enlightenment/data/config/netbook"
+FILES_${PN}-config-scaleable = "${datadir}/enlightenment/data/config/scaleable"
+FILES_${PN}-config-standard = "${datadir}/enlightenment/data/config/standard"
+FILES_${PN}-theme-default = "${datadir}/enlightenment/data/themes/default.edj"
+FILES_${PN}-theme-illume = "${datadir}/enlightenment/data/themes/illume.edj"
+FILES_${PN}-theme-default = "${datadir}/enlightenment/data/themes/default.edj"
+FILES_${PN}-background-dark-gradient = "${datadir}/enlightenment/data/backgrounds/Dark_Gradient.edj"
+FILES_${PN}-background-light-gradient = "${datadir}/enlightenment/data/backgrounds/Light_Gradient.edj"
+FILES_${PN}-images = "${datadir}/enlightenment/data/images"
+FILES_${PN}-icons = "${datadir}/enlightenment/data/icons"
+FILES_${PN}-other = "${datadir}/enlightenment/data/other"
+FILES_${PN}-input-methods = "${datadir}/enlightenment/data/input_methods"
+
+RRECOMMENDS_${PN}-config-default = "${PN}-theme-default"
+RRECOMMENDS_${PN}-config-illume = "${PN}-theme-illume"
+RRECOMMENDS_${PN}-config-minimalist = "${PN}-background-light-gradient \
+${PN}-theme-default"
+RRECOMMENDS_${PN}-config-netbook = "${PN}-background-dark-gradient \
+${PN}-theme-default"
+RRECOMMENDS_${PN}-config-scaleable = "${PN}-theme-default"
+RRECOMMENDS_${PN}-config-standard = "${PN}-theme-default"
+
FILES_${PN}-dbg += "\
${libdir}/enlightenment/modules/*/*/.debug/ \
${libdir}/enlightenment/preload/.debug/ \
"
-
-FILES_${PN}-dev += "\
- ${libdir}/enlightenment/preload/*.?a \
-"
+FILES_${PN}-dev += "${libdir}/enlightenment/preload/*.?a"
CONFFILES_${PN} = "/etc/xdg/menus/applications.menu"
diff --git a/packages/e17/illume-theme-illume_svn.bb b/packages/e17/illume-theme-illume_svn.bb
deleted file mode 100644
index eb313e074c..0000000000
--- a/packages/e17/illume-theme-illume_svn.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-DESCRIPTION = "Illume theme for Illume E module"
-HOMEPAGE = "http://www.enlightenment.org/"
-LICENSE = "MIT/BSD"
-DEPENDS = "edje-native eet-native"
-PV = "0.0+${PR}-svnr${SRCREV}"
-PR = "r1"
-
-SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk;module=THEMES/b_and_w;proto=http"
-S = "${WORKDIR}/THEMES/b_and_w"
-
-do_compile() {
- edje_cc illume.edc
- edje_cc illume_init.edc
-}
-
-do_install() {
- install -d ${D}${sysconfdir}/enlightenment
- install -d ${D}${datadir}/enlightenment/data/themes/
- install -d ${D}${datadir}/enlightenment/data/init/
-
- # FIXME: hack. should modify profile.cfg and nto use enlightenment_start.oe
- echo 'E_PROFILE="-profile illume"' > ${D}${sysconfdir}/enlightenment/default_profile
-
- install -m 0644 ${S}/illume.edj ${D}${datadir}/enlightenment/data/themes/
- install -m 0644 ${S}/illume_init.edj ${D}${datadir}/enlightenment/data/init/
-}
-
-RPROVIDES_${PN} = "illume-theme"
-CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"
-FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
-
-PACKAGE_ARCH_${PN} = "all"
-