aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ebtables
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/ebtables
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/ebtables')
-rw-r--r--packages/ebtables/ebtables-2.0.6/gcc34.patch16
-rw-r--r--packages/ebtables/ebtables-2.0.6/gcc4.patch67
-rw-r--r--packages/ebtables/ebtables-2.0.6/installcreatedirs.patch25
-rw-r--r--packages/ebtables/ebtables-2.0.6/installnonroot.patch55
-rw-r--r--packages/ebtables/ebtables_2.0.6.bb22
5 files changed, 0 insertions, 185 deletions
diff --git a/packages/ebtables/ebtables-2.0.6/gcc34.patch b/packages/ebtables/ebtables-2.0.6/gcc34.patch
deleted file mode 100644
index c5d341e225..0000000000
--- a/packages/ebtables/ebtables-2.0.6/gcc34.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- ebtables-v2.0.6/ebtables.c~gcc34 2003-11-02 12:22:56.000000000 -0600
-+++ ebtables-v2.0.6/ebtables.c 2004-06-03 13:27:28.000000000 -0500
-@@ -1170,7 +1170,7 @@
- if (!t->compare(t->t, u_e->t))
- continue;
- return i;
--letscontinue:
-+letscontinue:;
- }
- return -1;
- }
diff --git a/packages/ebtables/ebtables-2.0.6/gcc4.patch b/packages/ebtables/ebtables-2.0.6/gcc4.patch
deleted file mode 100644
index 6b3688a3d9..0000000000
--- a/packages/ebtables/ebtables-2.0.6/gcc4.patch
+++ /dev/null
@@ -1,67 +0,0 @@
---- ebtables-v2.0.6/extensions/ebt_ip.c 2006/09/01 02:27:02 1.1
-+++ ebtables-v2.0.6/extensions/ebt_ip.c 2006/09/01 02:27:30
-@@ -313,7 +313,7 @@
- ipinfo->invflags |= EBT_IP_PROTO;
- if (optind > argc)
- print_error("Missing IP protocol argument");
-- (unsigned char) i = strtoul(argv[optind - 1], &end, 10);
-+ i = strtoul(argv[optind - 1], &end, 10);
- if (*end != '\0') {
- struct protoent *pe;
-
---- ebtables-v2.0.6/extensions/ebt_vlan.c 2006/09/01 02:27:38 1.1
-+++ ebtables-v2.0.6/extensions/ebt_vlan.c 2006/09/01 02:28:01
-@@ -141,7 +141,7 @@
- check_option(flags, OPT_VLAN_ID);
- CHECK_INV_FLAG(EBT_VLAN_ID);
- CHECK_IF_MISSING_VALUE;
-- (unsigned short) local.id =
-+ local.id =
- strtoul(argv[optind - 1], &end, 10);
- CHECK_RANGE(local.id > 4094 || *end != '\0');
- vlaninfo->id = local.id;
-@@ -152,7 +152,7 @@
- check_option(flags, OPT_VLAN_PRIO);
- CHECK_INV_FLAG(EBT_VLAN_PRIO);
- CHECK_IF_MISSING_VALUE;
-- (unsigned char) local.prio =
-+ local.prio =
- strtoul(argv[optind - 1], &end, 10);
- CHECK_RANGE(local.prio >= 8 || *end != '\0');
- vlaninfo->prio = local.prio;
-@@ -163,7 +163,7 @@
- check_option(flags, OPT_VLAN_ENCAP);
- CHECK_INV_FLAG(EBT_VLAN_ENCAP);
- CHECK_IF_MISSING_VALUE;
-- (unsigned short) local.encap =
-+ local.encap =
- strtoul(argv[optind - 1], &end, 16);
- if (*end != '\0') {
- ethent = getethertypebyname(argv[optind - 1]);
---- ebtables-v2.0.6/extensions/ebt_limit.c 2006/09/01 02:28:09 1.1
-+++ ebtables-v2.0.6/extensions/ebt_limit.c 2006/09/01 02:30:21
-@@ -203,15 +203,15 @@
-
- static struct ebt_u_match limit_match =
- {
-- .name EBT_LIMIT_MATCH,
-- .size sizeof(struct ebt_limit_info),
-- .help print_help,
-- .init init,
-- .parse parse,
-- .final_check final_check,
-- .print print,
-- .compare compare,
-- .extra_ops opts,
-+ .name = EBT_LIMIT_MATCH,
-+ .size = sizeof(struct ebt_limit_info),
-+ .help = print_help,
-+ .init = init,
-+ .parse = parse,
-+ .final_check = final_check,
-+ .print = print,
-+ .compare = compare,
-+ .extra_ops = opts,
- };
-
- static void _init(void) __attribute((constructor));
diff --git a/packages/ebtables/ebtables-2.0.6/installcreatedirs.patch b/packages/ebtables/ebtables-2.0.6/installcreatedirs.patch
deleted file mode 100644
index 86bc4f0a44..0000000000
--- a/packages/ebtables/ebtables-2.0.6/installcreatedirs.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- ebtables-v2.0.6/Makefile~installcreatedirs 2004-06-03 13:34:17.000000000 -0500
-+++ ebtables-v2.0.6/Makefile 2004-06-03 13:35:21.000000000 -0500
-@@ -47,14 +47,17 @@
-
- $(MANDIR)/man8/ebtables.8: ebtables.8
- mkdir -p $(@D)
-+ install -d $(MANDIR)/man8
- install -m 0644 $(INSTALLOWN) $< $@
-
- $(ETHERTYPESFILE): ethertypes
- mkdir -p $(@D)
-+ install -d $(ETHERTYPESPATH)
- install -m 0644 $(INSTALLOWN) $< $@
-
- .PHONY: exec
- exec: ebtables
-+ install -d $(BINPATH)
- install -m 0755 $(INSTALLOWN) $< $(BINFILE)
-
- .PHONY: install
diff --git a/packages/ebtables/ebtables-2.0.6/installnonroot.patch b/packages/ebtables/ebtables-2.0.6/installnonroot.patch
deleted file mode 100644
index 0211e62364..0000000000
--- a/packages/ebtables/ebtables-2.0.6/installnonroot.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- ebtables-v2.0.6/Makefile~installnonroot 2003-11-02 12:22:56.000000000 -0600
-+++ ebtables-v2.0.6/Makefile 2004-06-03 13:34:17.000000000 -0500
-@@ -7,6 +7,7 @@
- MANDIR?=/usr/local/man
- CFLAGS:=-Wall -Wunused
- CC:=gcc
-+INSTALLOWN=$(if $(filter 0,$(shell id -u)),-o root -g root)
-
- ifeq ($(shell uname -m),sparc64)
- CFLAGS+=-DEBT_MIN_ALIGN=8 -DKERNEL_64_USERSPACE_32
-@@ -46,15 +47,15 @@
-
- $(MANDIR)/man8/ebtables.8: ebtables.8
- mkdir -p $(@D)
-- install -m 0644 -o root -g root $< $@
-+ install -m 0644 $(INSTALLOWN) $< $@
-
- $(ETHERTYPESFILE): ethertypes
- mkdir -p $(@D)
-- install -m 0644 -o root -g root $< $@
-+ install -m 0644 $(INSTALLOWN) $< $@
-
- .PHONY: exec
- exec: ebtables
-- install -m 0755 -o root -g root $< $(BINFILE)
-+ install -m 0755 $(INSTALLOWN) $< $(BINFILE)
-
- .PHONY: install
- install: $(MANDIR)/man8/ebtables.8 $(ETHERTYPESFILE) exec
-@@ -70,16 +71,16 @@
- .PHONY: release
- release:
- mkdir -p include/linux/netfilter_bridge
-- install -m 0644 -o root -g root \
-+ install -m 0644 $(INSTALLOWN) \
- $(KERNEL_INCLUDES)/linux/netfilter_bridge.h include/linux/
- # To keep possible compile error complaints about undefined ETH_P_8021Q
- # off my back
-- install -m 0644 -o root -g root \
-+ install -m 0644 $(INSTALLOWN) \
- $(KERNEL_INCLUDES)/linux/if_ether.h include/linux/
-- install -m 0644 -o root -g root \
-+ install -m 0644 $(INSTALLOWN) \
- $(KERNEL_INCLUDES)/linux/netfilter_bridge/*.h \
- include/linux/netfilter_bridge/
-- install -m 0644 -o root -g root \
-+ install -m 0644 $(INSTALLOWN) \
- include/ebtables.h include/linux/netfilter_bridge/
- make clean
- touch *
diff --git a/packages/ebtables/ebtables_2.0.6.bb b/packages/ebtables/ebtables_2.0.6.bb
deleted file mode 100644
index 33ad2b9113..0000000000
--- a/packages/ebtables/ebtables_2.0.6.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-DESCRIPTION = "Utility that enables basic Ethernet frame filtering on a Linux bridge, MAC NAT and brouting."
-PRIORITY = "optional"
-LICENSE = "GPL"
-SECTION = "console/network"
-PR = "r2"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/ebtables/ebtables-v${PV}.tar.gz \
- file://gcc34.patch;patch=1 \
- file://gcc4.patch;patch=1 \
- file://installnonroot.patch;patch=1 \
- file://installcreatedirs.patch;patch=1"
-S = "${WORKDIR}/ebtables-v${PV}"
-
-do_compile () {
- oe_runmake 'BINPATH=/sbin/' 'MANDIR=${mandir}/' \
- 'ETHERTYPESPATH=${sysconfdir}/' 'KERNEL_INCLUDES=${STAGING_INCDIR}'
-}
-
-do_install () {
- oe_runmake 'BINPATH=${D}${base_sbindir}/' 'MANDIR=${D}${mandir}/' \
- 'ETHERTYPESPATH=${D}${sysconfdir}/' install
-}