aboutsummaryrefslogtreecommitdiffstats
path: root/packages/efl/ewl_0.0.4.007.bb
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2006-05-12 19:33:42 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-12 19:33:42 +0000
commit5801f1d73d5dd9ab259000c9a606d304916c5a46 (patch)
tree269ee0e363abb426782c961170d330cc1642d609 /packages/efl/ewl_0.0.4.007.bb
parent3afa784bb8cba63d6ba8507d1d083224a51fa787 (diff)
downloadopenembedded-5801f1d73d5dd9ab259000c9a606d304916c5a46.tar.gz
efl, e17: update to newest versions
Diffstat (limited to 'packages/efl/ewl_0.0.4.007.bb')
-rw-r--r--packages/efl/ewl_0.0.4.007.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/efl/ewl_0.0.4.007.bb b/packages/efl/ewl_0.0.4.007.bb
new file mode 100644
index 0000000000..85b85e0c05
--- /dev/null
+++ b/packages/efl/ewl_0.0.4.007.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "The Enlightened Widget Library, \
+a simple-to-use general purpose widget library based on the enlightenment foundation libraries."
+# as of recent CVS HEAD, ewl no longer needs etox and no longer needs edb
+DEPENDS = "edb virtual/evas virtual/ecore edje emotion"
+RDEPENDS += "libewl-themes"
+LICENSE = "MIT"
+PR = "r1"
+
+inherit efl
+
+SRC_URI += "file://ewl-configure.patch;patch=1 \
+ file://fix-ecore.patch;patch=1 \
+ file://ecore-flags.patch;patch=1 \
+ file://no-examples.patch;patch=1 \
+ file://minmax.patch;patch=1"
+
+do_stage_append() {
+ for i in src/lib/ewl_*.h
+ do
+ install -m 0644 $i ${STAGING_INCDIR}
+ done
+}
+