aboutsummaryrefslogtreecommitdiffstats
path: root/packages/expat
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2008-08-01 21:39:13 +0000
committerKhem Raj <raj.khem@gmail.com>2008-08-01 21:39:13 +0000
commit4f697ca42208d4af3339f64595a46aa71f26bea1 (patch)
tree14589ea5a1150b372b66e6ee6d72a37744f08cae /packages/expat
parent2cefeaab530c24918e5d471c0d7790524c4b7414 (diff)
downloadopenembedded-4f697ca42208d4af3339f64595a46aa71f26bea1.tar.gz
Consider i386 when making XMLCALL as decl type.
This fixes gdb build failures on x86_64 host machines.
Diffstat (limited to 'packages/expat')
-rw-r--r--packages/expat/expat-1.95.7/expat-XMLCALL.patch17
-rw-r--r--packages/expat/expat_1.95.7.bb6
2 files changed, 21 insertions, 2 deletions
diff --git a/packages/expat/expat-1.95.7/expat-XMLCALL.patch b/packages/expat/expat-1.95.7/expat-XMLCALL.patch
new file mode 100644
index 0000000000..c688f06426
--- /dev/null
+++ b/packages/expat/expat-1.95.7/expat-XMLCALL.patch
@@ -0,0 +1,17 @@
+---
+ lib/expat.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: expat-1.95.7/lib/expat.h
+===================================================================
+--- expat-1.95.7.orig/lib/expat.h 2008-07-31 15:56:39.000000000 -0700
++++ expat-1.95.7/lib/expat.h 2008-07-31 15:58:38.000000000 -0700
+@@ -45,7 +45,7 @@
+ #ifndef XMLCALL
+ #if defined(XML_USE_MSC_EXTENSIONS)
+ #define XMLCALL __cdecl
+-#elif defined(__GNUC__)
++#elif defined(__GNUC__) && defined(__i386) && !defined(__INTEL_COMPILER)
+ #define XMLCALL __attribute__((cdecl))
+ #else
+ /* For any platform which uses this definition and supports more than
diff --git a/packages/expat/expat_1.95.7.bb b/packages/expat/expat_1.95.7.bb
index a4dda4dcb6..7b48305933 100644
--- a/packages/expat/expat_1.95.7.bb
+++ b/packages/expat/expat_1.95.7.bb
@@ -1,7 +1,9 @@
require expat.inc
-PR = "r1"
+PR = "r2"
-SRC_URI += "file://autotools.patch;patch=1"
+SRC_URI += "file://autotools.patch;patch=1 \
+ file://expat-XMLCALL.patch;patch=1 \
+ "
inherit lib_package