aboutsummaryrefslogtreecommitdiffstats
path: root/packages/expat
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/expat
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/expat')
-rw-r--r--packages/expat/expat_1.95.6.bb22
-rw-r--r--packages/expat/expat_1.95.7.bb29
2 files changed, 51 insertions, 0 deletions
diff --git a/packages/expat/expat_1.95.6.bb b/packages/expat/expat_1.95.6.bb
index e69de29bb2..f597b3f18d 100644
--- a/packages/expat/expat_1.95.6.bb
+++ b/packages/expat/expat_1.95.6.bb
@@ -0,0 +1,22 @@
+SECTION = "libs"
+DESCRIPTION = "Jim Clarkes XML parser library."
+LICENSE = "MIT"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.gz"
+S = "${WORKDIR}/expat-${PV}"
+
+inherit autotools
+export LTCC = "${CC}"
+
+do_stage () {
+ install -m 0644 ${S}/lib/expat.h ${STAGING_INCDIR}/
+ oe_libinstall -so libexpat ${STAGING_LIBDIR}/
+}
+
+do_install () {
+ oe_runmake prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ install
+}
diff --git a/packages/expat/expat_1.95.7.bb b/packages/expat/expat_1.95.7.bb
index e69de29bb2..95572ce84b 100644
--- a/packages/expat/expat_1.95.7.bb
+++ b/packages/expat/expat_1.95.7.bb
@@ -0,0 +1,29 @@
+SECTION = "libs"
+DESCRIPTION = "Jim Clarkes XML parser library."
+HOMEPAGE = "http://expat.sourceforge.net/"
+LICENSE = "MIT"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.gz \
+ file://autotools.patch;patch=1"
+S = "${WORKDIR}/expat-${PV}"
+
+inherit autotools lib_package
+export LTCC = "${CC}"
+
+do_configure () {
+ rm -f ${S}/conftools/libtool.m4
+ autotools_do_configure
+}
+
+do_stage () {
+ install -m 0644 ${S}/lib/expat.h ${STAGING_INCDIR}/
+ oe_libinstall -so libexpat ${STAGING_LIBDIR}
+}
+
+do_install () {
+ oe_runmake prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ install
+}