aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ez-ipupdate
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-11-28 07:19:35 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-28 07:19:35 +0000
commit872ed8f1882bc54a002b836aa6b136cde76eb229 (patch)
treecb45d1d738521acb18aeb72f61ad08c56e20a7d1 /packages/ez-ipupdate
parentaf8ec74a677aa9e7e5411ecc341a82480622ee74 (diff)
downloadopenembedded-872ed8f1882bc54a002b836aa6b136cde76eb229.tar.gz
ez-ipupdate: release 3.0.10
- fully tested release with startup script and prototype config - file. This package will update a wide range of dynamic IP services. - Tested on zoneedit.
Diffstat (limited to 'packages/ez-ipupdate')
-rw-r--r--packages/ez-ipupdate/.mtn2git_empty0
-rw-r--r--packages/ez-ipupdate/ez-ipupdate_3.0.10.bb32
-rw-r--r--packages/ez-ipupdate/files/.mtn2git_empty0
-rw-r--r--packages/ez-ipupdate/files/conffile.patch10
-rw-r--r--packages/ez-ipupdate/files/configure.patch11
-rw-r--r--packages/ez-ipupdate/files/init44
-rw-r--r--packages/ez-ipupdate/files/ipupdate.conf36
-rw-r--r--packages/ez-ipupdate/files/zoneedit.patch11
8 files changed, 144 insertions, 0 deletions
diff --git a/packages/ez-ipupdate/.mtn2git_empty b/packages/ez-ipupdate/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ez-ipupdate/.mtn2git_empty
diff --git a/packages/ez-ipupdate/ez-ipupdate_3.0.10.bb b/packages/ez-ipupdate/ez-ipupdate_3.0.10.bb
new file mode 100644
index 0000000000..62cd506d9f
--- /dev/null
+++ b/packages/ez-ipupdate/ez-ipupdate_3.0.10.bb
@@ -0,0 +1,32 @@
+# Angus Mackay's ez-ipupdate from www.ez-ipupdate.com
+DESCRIPTION = "A client for automatically updating your EZ-IP.net, justlinux.com, dhs.org, dyndns.org, ods.org, gnudip.cheapnet.net, tzo.com, easydns.com dynamic hostname parameters. Includes daemon support that only sends updates if your IP address changes."
+HOMEPAGE = "http://www.ez-ipupdate.com/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.ez-ipupdate.com/dist/ez-ipupdate-${PV}.tar.gz"
+SRC_URI += "file://configure.patch;patch=1"
+SRC_URI += "file://conffile.patch;patch=1"
+SRC_URI += "file://zoneedit.patch;patch=1"
+SRC_URI += "file://init"
+SRC_URI += "file://ipupdate.conf"
+
+INITSCRIPT_NAME = "ipupdate"
+# No dependencies, so just go in at the standard level (20)
+INITSCRIPT_PARAMS = "defaults"
+
+# The configuration file must be editted...
+CONFFILES_${PN} = "${sysconfdir}/ipupdate.conf"
+
+inherit autotools update-rc.d
+
+PACKAGES = "ez-ipupdate"
+
+do_install_append() {
+ install -d "${D}${sysconfdir}/init.d"
+ install -c -m 755 ${WORKDIR}/init "${D}${sysconfdir}/init.d/ipupdate"
+ install -c -m 644 ${WORKDIR}/ipupdate.conf "${D}${sysconfdir}/ipupdate.conf"
+}
diff --git a/packages/ez-ipupdate/files/.mtn2git_empty b/packages/ez-ipupdate/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ez-ipupdate/files/.mtn2git_empty
diff --git a/packages/ez-ipupdate/files/conffile.patch b/packages/ez-ipupdate/files/conffile.patch
new file mode 100644
index 0000000000..41f8a0e73b
--- /dev/null
+++ b/packages/ez-ipupdate/files/conffile.patch
@@ -0,0 +1,10 @@
+--- ez-ipupdate-3.0.10/conf_file.c.orig 2005-11-27 20:03:46.557322517 -0800
++++ ez-ipupdate-3.0.10/conf_file.c 2005-11-27 20:03:15.519369422 -0800
+@@ -34,6 +34,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <errno.h>
+
+ #include <conf_file.h>
+
diff --git a/packages/ez-ipupdate/files/configure.patch b/packages/ez-ipupdate/files/configure.patch
new file mode 100644
index 0000000000..e6a945e4b2
--- /dev/null
+++ b/packages/ez-ipupdate/files/configure.patch
@@ -0,0 +1,11 @@
+--- ez-ipupdate-3.0.10/Makefile.am.orig 2005-11-27 15:24:05.857379643 -0800
++++ ez-ipupdate-3.0.10/Makefile.am 2005-11-27 19:35:58.832379202 -0800
+@@ -1,7 +1,6 @@
+
+ bin_PROGRAMS = ez-ipupdate
+-ez_ipupdate_SOURCES = ez-ipupdate.c conf_file.c conf_file.h md5.c md5.h cache_file.c cache_file.h error.h pid_file.c pid_file.h dprintf.h @EXTRASRC@
+-ez_ipupdate_LDADD = @EXTRAOBJ@
++ez_ipupdate_SOURCES = ez-ipupdate.c conf_file.c conf_file.h md5.c md5.h cache_file.c cache_file.h error.h pid_file.c pid_file.h dprintf.h
+
+ EXTRA_DIST = getpass.c ez-ipupdate.lsm example.conf example-pgpow.conf example-dhs.conf example-dyndns.conf example-ods.conf example-tzo.conf example-gnudip.conf example-easydns.conf example-justlinux.conf example-dyns.conf CHANGELOG mkbinary
+
diff --git a/packages/ez-ipupdate/files/init b/packages/ez-ipupdate/files/init
new file mode 100644
index 0000000000..031c33c79b
--- /dev/null
+++ b/packages/ez-ipupdate/files/init
@@ -0,0 +1,44 @@
+#!/bin/sh
+#
+# ipupdate init.d script for ez-ipupdate
+#
+# You *must* create or update the /etc/ipupdate.conf file for
+# this to work
+CONF=/etc/ipupdate.conf
+PIDFILE=/var/run/ipupdate.pid
+test -x /usr/bin/ez-ipupdate -a -r "${CONF}" || exit 0
+if egrep '^service-type=<type of service>$' "${CONF}" >/dev/null
+then
+ # conf file not editted
+ exit 0
+fi
+
+case "$1" in
+ start)
+ echo -n "Starting ez-ipupdate: "
+ start-stop-daemon --start -x /usr/bin/ez-ipupdate -- -c "${CONF}" -d -F "${PIDFILE}" "$@"
+ echo "done"
+ ;;
+ stop)
+ echo -n "Stopping ez-ipupdate: "
+ start-stop-daemon --stop -s 3 -p "${PIDFILE}"
+ echo "done"
+ ;;
+ restart)
+ echo -n "Restarting ez-ipupdate: "
+ start-stop-daemon --stop -s 3 -p "${PIDFILE}"
+ start-stop-daemon --start -x /usr/bin/ez-ipupdate -- -c "${CONF}" -d -F "${PIDFILE}" "$@"
+ echo "done"
+ ;;
+ force-reload|reload)
+ # HUP causes a reload, a simple TERM causes the daemon
+ # to wake up and re-update the IP address
+ start-stop-daemon --stop -s 1 -p "${PIDFILE}"
+ ;;
+ *)
+ echo "Usage: ipupdate { start | stop | restart | reload }" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/packages/ez-ipupdate/files/ipupdate.conf b/packages/ez-ipupdate/files/ipupdate.conf
new file mode 100644
index 0000000000..cbba491ef6
--- /dev/null
+++ b/packages/ez-ipupdate/files/ipupdate.conf
@@ -0,0 +1,36 @@
+#!/usr/bin/ez-ipupdate -c
+#
+# example config file for ez-ipupdate
+#
+# this file is actually executable!
+#
+#CHANGE this to the service name (ez-ipupdate --help for the list)
+service-type=<type of service>
+#CHANGE this to the user name and password on the service
+user=myuserid:mypassword
+#CHANGE this to the domain name to update
+host=mydomain.whatever.com
+#
+interface=eth0
+quiet
+#
+# other options:
+#address=<ip address>
+#cache-file=/etc/ez-ipupdate.cache.eth1
+#daemon
+#debug
+#foreground
+#host=<host>
+#interface=<interface>
+#mx=<mail exchanger>
+#retrys=<number of trys>
+#run-as-user=<user>
+#server=<server name>
+#timeout=<sec.millisec>
+#max-interval=<time in seconds>
+#notify-email=<email address>
+#period=<time between update attempts>
+#url=<url>
+#user=<user name>[:password]
+#wildcard
+#quiet
diff --git a/packages/ez-ipupdate/files/zoneedit.patch b/packages/ez-ipupdate/files/zoneedit.patch
new file mode 100644
index 0000000000..c9d4e4a2c1
--- /dev/null
+++ b/packages/ez-ipupdate/files/zoneedit.patch
@@ -0,0 +1,11 @@
+--- ez-ipupdate-3.0.10/ez-ipupdate.c.orig 2005-11-27 22:59:39.149355269 -0800
++++ ez-ipupdate-3.0.10/ez-ipupdate.c 2005-11-27 22:59:46.705830768 -0800
+@@ -3806,7 +3806,7 @@ int ZONEEDIT_update_entry(void)
+ break;
+
+ case 200:
+- if(strstr(buf, "<SUCCESS\n") != NULL)
++ if(strstr(buf, "<SUCCESS ") != NULL)
+ {
+ if(!(options & OPT_QUIET))
+ {