aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ezx
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-12-06 17:42:26 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-12-06 17:42:26 +0100
commit1aedd0303d93a92d0fc01545f5e5513c3bf7762b (patch)
tree3f798f09936a763125d9b303a533f5f8cda1e195 /packages/ezx
parent5b9e5c6108e8517473a5ae13acaa75ff32bd0619 (diff)
downloadopenembedded-1aedd0303d93a92d0fc01545f5e5513c3bf7762b.tar.gz
ezx-boot-usb-native: catch up with new developments & remove outdated versions
Diffstat (limited to 'packages/ezx')
-rw-r--r--packages/ezx/ezx-boot-usb-native.inc32
-rw-r--r--packages/ezx/ezx-boot-usb-native_0.1.0.bb7
-rw-r--r--packages/ezx/ezx-boot-usb-native_0.2.0.bb5
-rw-r--r--packages/ezx/ezx-boot-usb-native_svn.bb29
-rw-r--r--packages/ezx/files/asm-arm/setup.h226
5 files changed, 26 insertions, 273 deletions
diff --git a/packages/ezx/ezx-boot-usb-native.inc b/packages/ezx/ezx-boot-usb-native.inc
deleted file mode 100644
index e2ebb52df4..0000000000
--- a/packages/ezx/ezx-boot-usb-native.inc
+++ /dev/null
@@ -1,32 +0,0 @@
-DESCRIPTION = "Boots a Motorola EZX device with a user supplied kernel zImage"
-DEPENDS = "libusb-native"
-SECTION = "devel"
-AUTHOR = "Harald Welte <laforge@openezx.org>"
-LICENSE = "GPL"
-
-SRC_URI = "\
- svn://svn.openezx.org/trunk/src/host;module=boot_usb;proto=http \
- file://asm-arm \
-"
-S = "${WORKDIR}/boot_usb"
-
-inherit native
-
-do_compile() {
- ${CC} -I${WORKDIR} ${CFLAGS} ${LDFLAGS} -lusb -o ezx-boot-usb boot_usb.c
-}
-
-do_deploy() {
- install -d ${DEPLOY_DIR_TOOLS}
- install -m 0755 ezx-boot-usb ${DEPLOY_DIR_TOOLS}/ezx-boot-usb-${PV}
-}
-
-do_stage() {
- :
-}
-
-do_install() {
- :
-}
-
-addtask deploy before do_build after do_compile
diff --git a/packages/ezx/ezx-boot-usb-native_0.1.0.bb b/packages/ezx/ezx-boot-usb-native_0.1.0.bb
deleted file mode 100644
index b70aca3709..0000000000
--- a/packages/ezx/ezx-boot-usb-native_0.1.0.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require ezx-boot-usb-native.inc
-PR = "r0"
-
-SRC_URI = "http://www.openezx.org/download/boot_usb-${PV}.tar.bz2"
-S = "${WORKDIR}/boot_usb-${PV}"
-
-inherit native
diff --git a/packages/ezx/ezx-boot-usb-native_0.2.0.bb b/packages/ezx/ezx-boot-usb-native_0.2.0.bb
deleted file mode 100644
index 7c2883b5b7..0000000000
--- a/packages/ezx/ezx-boot-usb-native_0.2.0.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-require ezx-boot-usb-native.inc
-
-SRC_URI = "http://www.openezx.org/download/boot_usb-${PV}.tar.bz2 \
- file://asm-arm"
-S = "${WORKDIR}/boot_usb-${PV}"
diff --git a/packages/ezx/ezx-boot-usb-native_svn.bb b/packages/ezx/ezx-boot-usb-native_svn.bb
index 6ab4263dba..a0a8affdc0 100644
--- a/packages/ezx/ezx-boot-usb-native_svn.bb
+++ b/packages/ezx/ezx-boot-usb-native_svn.bb
@@ -1,5 +1,28 @@
-require ezx-boot-usb-native.inc
+DESCRIPTION = "Boots a Motorola EZX device with a user supplied kernel zImage"
+DEPENDS = "libusb-native virtual/kernel"
+SECTION = "devel"
+AUTHOR = "Team OpenEZX <openezx-devel@lists.openezx.org>"
+LICENSE = "GPL"
+PV = "0.2.0+svnr${SRCREV}"
-DEFAULT_PREFERENCE = "-1"
+SRC_URI = "svn://svn.openezx.org/trunk/src/host;module=boot_usb;proto=http"
+S = "${WORKDIR}/boot_usb"
-PV = "0.2.0+r${SRCREV}"
+EXTRA_OECONF := '--with-kernel-dir="${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"'
+
+inherit autotools native
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_TOOLS}
+ install -m 0755 boot_usb ${DEPLOY_DIR_TOOLS}/ezx-boot-usb-${PV}
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ :
+}
+
+addtask deploy before do_build after do_compile
diff --git a/packages/ezx/files/asm-arm/setup.h b/packages/ezx/files/asm-arm/setup.h
deleted file mode 100644
index 7bbf105463..0000000000
--- a/packages/ezx/files/asm-arm/setup.h
+++ /dev/null
@@ -1,226 +0,0 @@
-/*
- * linux/include/asm/setup.h
- *
- * Copyright (C) 1997-1999 Russell King
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License version 2 as
- * published by the Free Software Foundation.
- *
- * Structure passed to kernel to tell it about the
- * hardware it's running on. See Documentation/arm/Setup
- * for more info.
- */
-#ifndef __ASMARM_SETUP_H
-#define __ASMARM_SETUP_H
-
-#include <asm/types.h>
-
-#define COMMAND_LINE_SIZE 1024
-
-/* The list ends with an ATAG_NONE node. */
-#define ATAG_NONE 0x00000000
-
-struct tag_header {
- __u32 size;
- __u32 tag;
-};
-
-/* The list must start with an ATAG_CORE node */
-#define ATAG_CORE 0x54410001
-
-struct tag_core {
- __u32 flags; /* bit 0 = read-only */
- __u32 pagesize;
- __u32 rootdev;
-};
-
-/* it is allowed to have multiple ATAG_MEM nodes */
-#define ATAG_MEM 0x54410002
-
-struct tag_mem32 {
- __u32 size;
- __u32 start; /* physical start address */
-};
-
-/* VGA text type displays */
-#define ATAG_VIDEOTEXT 0x54410003
-
-struct tag_videotext {
- __u8 x;
- __u8 y;
- __u16 video_page;
- __u8 video_mode;
- __u8 video_cols;
- __u16 video_ega_bx;
- __u8 video_lines;
- __u8 video_isvga;
- __u16 video_points;
-};
-
-/* describes how the ramdisk will be used in kernel */
-#define ATAG_RAMDISK 0x54410004
-
-struct tag_ramdisk {
- __u32 flags; /* bit 0 = load, bit 1 = prompt */
- __u32 size; /* decompressed ramdisk size in _kilo_ bytes */
- __u32 start; /* starting block of floppy-based RAM disk image */
-};
-
-/* describes where the compressed ramdisk image lives (virtual address) */
-/*
- * this one accidentally used virtual addresses - as such,
- * it's deprecated.
- */
-#define ATAG_INITRD 0x54410005
-
-/* describes where the compressed ramdisk image lives (physical address) */
-#define ATAG_INITRD2 0x54420005
-
-struct tag_initrd {
- __u32 start; /* physical start address */
- __u32 size; /* size of compressed ramdisk image in bytes */
-};
-
-/* board serial number. "64 bits should be enough for everybody" */
-#define ATAG_SERIAL 0x54410006
-
-struct tag_serialnr {
- __u32 low;
- __u32 high;
-};
-
-/* board revision */
-#define ATAG_REVISION 0x54410007
-
-struct tag_revision {
- __u32 rev;
-};
-
-/* initial values for vesafb-type framebuffers. see struct screen_info
- * in include/linux/tty.h
- */
-#define ATAG_VIDEOLFB 0x54410008
-
-struct tag_videolfb {
- __u16 lfb_width;
- __u16 lfb_height;
- __u16 lfb_depth;
- __u16 lfb_linelength;
- __u32 lfb_base;
- __u32 lfb_size;
- __u8 red_size;
- __u8 red_pos;
- __u8 green_size;
- __u8 green_pos;
- __u8 blue_size;
- __u8 blue_pos;
- __u8 rsvd_size;
- __u8 rsvd_pos;
-};
-
-/* command line: \0 terminated string */
-#define ATAG_CMDLINE 0x54410009
-
-struct tag_cmdline {
- char cmdline[1]; /* this is the minimum size */
-};
-
-/* acorn RiscPC specific information */
-#define ATAG_ACORN 0x41000101
-
-struct tag_acorn {
- __u32 memc_control_reg;
- __u32 vram_pages;
- __u8 sounddefault;
- __u8 adfsdrives;
-};
-
-/* footbridge memory clock, see arch/arm/mach-footbridge/arch.c */
-#define ATAG_MEMCLK 0x41000402
-
-struct tag_memclk {
- __u32 fmemclk;
-};
-
-struct tag {
- struct tag_header hdr;
- union {
- struct tag_core core;
- struct tag_mem32 mem;
- struct tag_videotext videotext;
- struct tag_ramdisk ramdisk;
- struct tag_initrd initrd;
- struct tag_serialnr serialnr;
- struct tag_revision revision;
- struct tag_videolfb videolfb;
- struct tag_cmdline cmdline;
-
- /*
- * Acorn specific
- */
- struct tag_acorn acorn;
-
- /*
- * DC21285 specific
- */
- struct tag_memclk memclk;
- } u;
-};
-
-struct tagtable {
- __u32 tag;
- int (*parse)(const struct tag *);
-};
-
-#define tag_member_present(tag,member) \
- ((unsigned long)(&((struct tag *)0L)->member + 1) \
- <= (tag)->hdr.size * 4)
-
-#define tag_next(t) ((struct tag *)((__u32 *)(t) + (t)->hdr.size))
-#define tag_size(type) ((sizeof(struct tag_header) + sizeof(struct type)) >> 2)
-
-#define for_each_tag(t,base) \
- for (t = base; t->hdr.size; t = tag_next(t))
-
-#ifdef __KERNEL__
-
-#define __tag __used __attribute__((__section__(".taglist.init")))
-#define __tagtable(tag, fn) \
-static struct tagtable __tagtable_##fn __tag = { tag, fn }
-
-/*
- * Memory map description
- */
-#ifdef CONFIG_ARCH_LH7A40X
-# define NR_BANKS 16
-#else
-# define NR_BANKS 8
-#endif
-
-struct membank {
- unsigned long start;
- unsigned long size;
- int node;
-};
-
-struct meminfo {
- int nr_banks;
- struct membank bank[NR_BANKS];
-};
-
-/*
- * Early command line parameters.
- */
-struct early_params {
- const char *arg;
- void (*fn)(char **p);
-};
-
-#define __early_param(name,fn) \
-static struct early_params __early_##fn __used \
-__attribute__((__section__(".early_param.init"))) = { name, fn }
-
-#endif /* __KERNEL__ */
-
-#endif