aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ezx
diff options
context:
space:
mode:
authorDaniel Willmann <daniel@totalueberwachung.de>2007-03-02 10:15:21 +0000
committerKoen Kooi <koen@openembedded.org>2007-03-02 10:15:21 +0000
commitf1e577d4fb289926eea6d44042c245cbcfdeefb2 (patch)
tree823cfcbf17cf787cf394d35ed6f38c4b65350090 /packages/ezx
parent1d8d537f48d92a558c243f49c39f3d70a483dd5e (diff)
downloadopenembedded-f1e577d4fb289926eea6d44042c245cbcfdeefb2.tar.gz
opentapi: start up real early to initialize the BP properly to stop the phone shutting of because udev is so slow
Diffstat (limited to 'packages/ezx')
-rw-r--r--packages/ezx/opentapi/opentapi.init4
-rw-r--r--packages/ezx/opentapi_svn.bb8
2 files changed, 8 insertions, 4 deletions
diff --git a/packages/ezx/opentapi/opentapi.init b/packages/ezx/opentapi/opentapi.init
index 593411e755..0b41418e00 100644
--- a/packages/ezx/opentapi/opentapi.init
+++ b/packages/ezx/opentapi/opentapi.init
@@ -37,8 +37,10 @@ start_it_up()
fi
echo -n "Starting $DESC: "
- start-stop-daemon --start --quiet --pidfile $PIDFILE \
+ start-stop-daemon --start --background --quiet --pidfile $PIDFILE \
--exec $DAEMON -- --system $PARAMS
+ # We need to sleep here because opening the mux devices takes some time
+ sleep 15
echo "$NAME."
if [ -d $EVENTDIR ]; then
run-parts --arg=start $EVENTDIR
diff --git a/packages/ezx/opentapi_svn.bb b/packages/ezx/opentapi_svn.bb
index a5abe7d756..e27b2fbe6c 100644
--- a/packages/ezx/opentapi_svn.bb
+++ b/packages/ezx/opentapi_svn.bb
@@ -1,8 +1,10 @@
-DESCRIPTION = "Open implementation of motorola's tapisrc"
+DESCRIPTION = "Open implementation of motorola's tapisrv"
LICENSE = "GPLv2"
+SECTION = "devel"
+AUTHOR = "Daniel Willmann"
PV = "0.0+svn${SRCDATE}"
-PR = "r2"
+PR = "r3"
SRC_URI = "svn://svn.openezx.org/trunk/src/userspace/;module=opentapi;proto=http \
file://opentapi.init \
@@ -11,7 +13,7 @@ SRC_URI = "svn://svn.openezx.org/trunk/src/userspace/;module=opentapi;proto=http
inherit update-rc.d
INITSCRIPT_NAME = "opentapi"
-INITSCRIPT_PARAMS = "start 04 S ."
+INITSCRIPT_PARAMS = "start 00 S ."
S = "${WORKDIR}/${PN}"