aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fakeroot
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-03-13 10:29:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-13 10:29:37 +0000
commit581beffb05246c92f3683d705f840b605ed6c9fe (patch)
tree38e4335714dafce9496088b8259c464ed3ade7a6 /packages/fakeroot
parent261eb19e87ece7897d3f6d803028c8ace9f1c4a2 (diff)
downloadopenembedded-581beffb05246c92f3683d705f840b605ed6c9fe.tar.gz
conf/documentation.conf:
Document the HOST_NONSYSV variable introduced by emte packages/fakeroot/fakeroot-native: There are systems without SYSV stuff. Introduce a HOST_NONSYSV variable if you have such a host system. In this case fakeroot-native is build with tcp IPC. This fixes bug #735 and patch is courtsey nigel Kostiuck (emte)
Diffstat (limited to 'packages/fakeroot')
-rw-r--r--packages/fakeroot/fakeroot-native_1.2.13.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/packages/fakeroot/fakeroot-native_1.2.13.bb b/packages/fakeroot/fakeroot-native_1.2.13.bb
index 4df6eeb5c5..cc3dfd2231 100644
--- a/packages/fakeroot/fakeroot-native_1.2.13.bb
+++ b/packages/fakeroot/fakeroot-native_1.2.13.bb
@@ -6,7 +6,13 @@ inherit native
SRC_URI += "file://fix-prefix.patch;patch=1"
S = "${WORKDIR}/fakeroot-${PV}"
-EXTRA_OECONF = "--program-prefix="
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
do_stage_append () {
oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/