aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fastcgi
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2008-07-09 19:07:36 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2008-07-09 19:07:36 +0000
commit45c6f45b3a33ed8ce1c20f4cd41e0a2b8f3c18e7 (patch)
treedc0d8a9f2d57b16586bd40d070e0c01371f1cc3a /packages/fastcgi
parent226038aa8f33be3c42eb56f5622f335a12b795b7 (diff)
downloadopenembedded-45c6f45b3a33ed8ce1c20f4cd41e0a2b8f3c18e7.tar.gz
fastcgi: Link with -lm. uclibc requires this. Fixes #4421.
Diffstat (limited to 'packages/fastcgi')
-rw-r--r--packages/fastcgi/fastcgi_2.4.0.bb8
-rw-r--r--packages/fastcgi/files/.mtn2git_empty0
-rw-r--r--packages/fastcgi/files/link-against-math.patch26
3 files changed, 29 insertions, 5 deletions
diff --git a/packages/fastcgi/fastcgi_2.4.0.bb b/packages/fastcgi/fastcgi_2.4.0.bb
index beada396cd..4c70aa3461 100644
--- a/packages/fastcgi/fastcgi_2.4.0.bb
+++ b/packages/fastcgi/fastcgi_2.4.0.bb
@@ -1,8 +1,9 @@
LICENSE = "Open Market"
DESCRIPTION = "Fast CGI backend (web server to CGI handler) library"
-PR = "r1"
+PR = "r2"
-SRC_URI = "http://www.fastcgi.com/dist/fcgi-${PV}.tar.gz"
+SRC_URI = "http://www.fastcgi.com/dist/fcgi-${PV}.tar.gz \
+file://link-against-math.patch;patch=1"
S=${WORKDIR}/fcgi-${PV}
@@ -16,6 +17,3 @@ do_stage() {
autotools_stage_all
}
-do_compile() {
-}
-
diff --git a/packages/fastcgi/files/.mtn2git_empty b/packages/fastcgi/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/fastcgi/files/.mtn2git_empty
diff --git a/packages/fastcgi/files/link-against-math.patch b/packages/fastcgi/files/link-against-math.patch
new file mode 100644
index 0000000000..37a9a038ce
--- /dev/null
+++ b/packages/fastcgi/files/link-against-math.patch
@@ -0,0 +1,26 @@
+Need to link against the C math library (-lm) at least for uclibc.
+
+Index: fcgi-2.4.0/cgi-fcgi/Makefile.am
+===================================================================
+--- fcgi-2.4.0.orig/cgi-fcgi/Makefile.am 2008-07-09 20:54:56.000000000 +0200
++++ fcgi-2.4.0/cgi-fcgi/Makefile.am 2008-07-09 20:55:12.000000000 +0200
+@@ -11,5 +11,5 @@
+ LIBDIR = ../libfcgi
+ LIBFCGI = $(LIBDIR)/libfcgi.la
+
+-LDADD = $(LIBFCGI)
++LDADD = $(LIBFCGI) -lm
+ cgi_fcgi_SOURCES = $(INCLUDE_FILES) cgi-fcgi.c
+Index: fcgi-2.4.0/examples/Makefile.am
+===================================================================
+--- fcgi-2.4.0.orig/examples/Makefile.am 2008-07-09 20:54:56.000000000 +0200
++++ fcgi-2.4.0/examples/Makefile.am 2008-07-09 20:55:11.000000000 +0200
+@@ -21,7 +21,7 @@
+ LIBDIR = ../libfcgi
+ LIBFCGI = $(LIBDIR)/libfcgi.la
+
+-LDADD = $(LIBFCGI)
++LDADD = $(LIBFCGI) -lm
+
+ echo_SOURCES = $(INCLUDE_FILES) echo.c
+ echo_x_SOURCES = $(INCLUDE_FILES) echo-x.c