aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fastjar
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2007-08-13 20:45:17 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2007-08-13 20:45:17 +0000
commitcbdb9b89fd14ffaf21c0f3e95d611b1b091d13e7 (patch)
treeabf91f992875b7b8da1851fad64496819ff43414 /packages/fastjar
parent0ba132234aaef39d858e7a714dc969991a846260 (diff)
downloadopenembedded-cbdb9b89fd14ffaf21c0f3e95d611b1b091d13e7.tar.gz
fastjar-native: newer upstream-version of fastjar
* fastjar now hosted at savannah.nongnu.org * depends on zlib-native instead of zlib
Diffstat (limited to 'packages/fastjar')
-rw-r--r--packages/fastjar/fastjar-native_0.95.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/fastjar/fastjar-native_0.95.bb b/packages/fastjar/fastjar-native_0.95.bb
new file mode 100644
index 0000000000..520235d799
--- /dev/null
+++ b/packages/fastjar/fastjar-native_0.95.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "jar replacement written in C."
+HOMEPAGE = "http://savannah.nongnu.org/projects/fastjar/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "zlib-native"
+
+SRC_URI = "http://download.savannah.nongnu.org/releases/fastjar/fastjar-${PV}.tar.gz"
+
+S = "${WORKDIR}/fastjar-${PV}"
+
+inherit autotools native
+
+EXTRA_OECONF = "--with-system-zlib --with-fastjar"
+
+do_configure () {
+ gnu-configize || die "failure running gnu-configize"
+ oe_runconf
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 fastjar ${STAGING_BINDIR}/fastjar
+ install -m 755 grepjar ${STAGING_BINDIR}
+}