aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fbpanel/fbpanel_4.3.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-02-27 16:36:08 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-27 16:36:08 +0000
commita57caf41363da33d64559a93c3915aa193d2a7a6 (patch)
treed2ba521ddd037203af8e16d0c51a4f8b2ac00bc9 /packages/fbpanel/fbpanel_4.3.bb
parent33831da957d614e45f01abde50d0c60a94be4508 (diff)
downloadopenembedded-a57caf41363da33d64559a93c3915aa193d2a7a6.tar.gz
fbpanel_4.3.bb : Add fbpanel, a lightweight gtk+ based panel
Diffstat (limited to 'packages/fbpanel/fbpanel_4.3.bb')
-rw-r--r--packages/fbpanel/fbpanel_4.3.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/fbpanel/fbpanel_4.3.bb b/packages/fbpanel/fbpanel_4.3.bb
new file mode 100644
index 0000000000..c237172ac8
--- /dev/null
+++ b/packages/fbpanel/fbpanel_4.3.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "A gtk based panel application"
+SECTION = "x11"
+LICENSE = "GPL"
+DEPENDS = "gtk+"
+HOMEPAGE = "http://fbpanel.sourceforge.net/"
+MAINTAINER = "Graeme Gregory <dp@xora.org.uk>"
+SRC_URI = "${SOURCEFORGE_MIRROR}/fbpanel/fbpanel-${PV}.tgz \
+ file://makefile.common.patch;patch=1 "
+
+PR = "r0"
+
+do_configure () {
+ ./configure --prefix=/usr --cpu=on
+}
+
+do_compile () {
+ oe_runmake CHATTY=1 STATIC_PLUGINS=1
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 fbpanel ${D}${bindir}
+ install -d ${D}${datadir}/fbpanel/
+ #install -d ${D}${datadir}/fbpanel/plugins
+ #install -m 644 plugins/*.so ${D}${datadir}/fbpanel/plugins
+ #install -m 644 systray/tray.so ${D}${datadir}/fbpanel/plugins
+ install -m 644 config/default ${D}${datadir}/fbpanel/default
+ install -d ${D}${datadir}/fbpanel/images
+ install -m 644 config/images/* ${D}${datadir}/fbpanel/images
+}
+