aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fbpanel
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2008-12-12 12:16:46 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2008-12-19 17:44:39 -0200
commit5d1879fe4cba581108c5ae5e5f70e56a4eba02b5 (patch)
tree07eda0266e5f6a60218a5570cd387da7fe2f3108 /packages/fbpanel
parentc22ce1100031a7e652c0ecd58f03278094378baf (diff)
downloadopenembedded-5d1879fe4cba581108c5ae5e5f70e56a4eba02b5.tar.gz
fbpanel: add 4.12
Diffstat (limited to 'packages/fbpanel')
-rw-r--r--packages/fbpanel/fbpanel_4.12.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/fbpanel/fbpanel_4.12.bb b/packages/fbpanel/fbpanel_4.12.bb
new file mode 100644
index 0000000000..6c5997fea2
--- /dev/null
+++ b/packages/fbpanel/fbpanel_4.12.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "A gtk based panel application"
+SECTION = "x11"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libxmu libxpm"
+HOMEPAGE = "http://fbpanel.sourceforge.net/"
+SRC_URI = "${SOURCEFORGE_MIRROR}/fbpanel/fbpanel-${PV}.tgz"
+
+PR = "r1"
+
+LDFLAGS += "-Wl,--export-dynamic"
+
+do_configure () {
+ ./configure --prefix=/usr --cpu=on
+}
+
+do_compile () {
+ oe_runmake CHATTY=1
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 fbpanel ${D}${bindir}
+ install -d ${D}${datadir}/fbpanel/
+ install -d ${D}${datadir}/fbpanel/plugins
+ install -m 644 plugins/*.so ${D}${datadir}/fbpanel/plugins
+ install -m 644 systray/tray.so ${D}${datadir}/fbpanel/plugins
+ install -m 644 config/default ${D}${datadir}/fbpanel/default
+ install -d ${D}${datadir}/fbpanel/images
+ install -m 644 config/images/* ${D}${datadir}/fbpanel/images
+}